CVE Catalog

CVE-2023-7315

MediumCVSS 5.4
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.51%

42th percentile - higher than 42% of all known CVEs

Summary

Nagios XI versions prior to 5.11.3 are vulnerable to cross-site scripting (XSS) via the Graph Explorer component. Insufficient validation or escaping of user-supplied input may allow an attacker to inject and execute arbitrary script in the context of a victim's browser.

Risk Assessment

An attacker can execute arbitrary script in the browser of a logged-in Nagios XI user, potentially leading to session theft or modification of monitoring configuration.

Recommendation

Update Nagios XI to version 5.11.3 or later. Until patched, restrict access to the web interface to trusted networks.

Other vulnerabilities in Nagios XI

See all
Original NVD description (English source)

Nagios XI versions prior to 5.11.3 are vulnerable to cross-site scripting (XSS) via the Graph Explorer component. Insufficient validation or escaping of user-supplied input may allow an attacker to inject and execute arbitrary script in the context of a victim's browser.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS