CVE Catalog

CVE-2023-51764

MediumCVSS 5.3
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

High risk
2.64%

85th percentile - higher than 85% of all known CVEs

Summary

Postfix through 3.8.5 is vulnerable to SMTP smuggling unless configured with smtpd_data_restrictions=reject_unauth_pipelining and smtpd_discard_ehlo_keywords=chunking (or certain other options in recent versions). Remote attackers can use a published exploitation technique to inject e-mail messages with a spoofed MAIL FROM address, allowing bypass of SPF protection. This occurs because Postfix supports <LF>.<CR><LF> while some other popular e-mail servers do not.

Risk Assessment

The organization may face SPF bypass, enabling spoofed emails that impersonate legitimate domains, increasing phishing risk and reputational damage.

Recommendation

Upgrade Postfix to at least 3.5.23, 3.6.13, 3.7.9, 3.8.4, or 3.9 and enable smtpd_forbid_bare_newline=yes to prevent all attack variants.

Other vulnerabilities in Postfix

Original NVD description (English source)

Postfix through 3.8.5 allows SMTP smuggling unless configured with smtpd_data_restrictions=reject_unauth_pipelining and smtpd_discard_ehlo_keywords=chunking (or certain other options that exist in recent versions). Remote attackers can use a published exploitation technique to inject e-mail messages with a spoofed MAIL FROM address, allowing bypass of an SPF protection mechanism. This occurs because Postfix supports <LF>.<CR><LF> but some other popular e-mail servers do not. To prevent attack variants (by always disallowing <LF> without <CR>), a different solution is required, such as the smtpd_forbid_bare_newline=yes option with a Postfix minimum version of 3.5.23, 3.6.13, 3.7.9, 3.8.4, or 3.9.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS