CVE Catalog

CVE-2023-28666

MediumCVSS 5.4
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.44%

37th percentile - higher than 37% of all known CVEs

Summary

The InPost Gallery WordPress plugin in versions before 2.2.2 is affected by a reflected cross-site scripting vulnerability in the 'imgurl' parameter of the add_inpost_gallery_slide_item action. It can only be triggered by an authenticated user.

Risk Assessment

An authenticated attacker can inject a malicious script that executes in another WordPress user's browser, potentially leading to session hijacking or unwanted actions.

Recommendation

Update the InPost Gallery plugin to version 2.2.2 or later and limit WordPress account privileges to the minimum necessary.

Related vulnerabilities

Original NVD description (English source)

The InPost Gallery WordPress plugin, in versions < 2.2.2, is affected by a reflected cross-site scripting vulnerability in the 'imgurl' parameter to the add_inpost_gallery_slide_item action, which can only be triggered by an authenticated user.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS