CVE Catalog

CVE-2023-27536

MediumCVSS 5.9
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

High risk
1.76%

78th percentile - higher than 78% of all known CVEs

Summary

An authentication bypass vulnerability exists in libcurl before 8.0.0 in the connection reuse feature. Failure to check for changes in CURLOPT_GSSAPI_DELEGATION can reuse connections with incorrect user permissions, affecting krb5/kerberos/negotiate/GSSAPI transfers.

Risk Assessment

Potential unauthorized access to sensitive information due to reuse of connections with incorrect permissions. Applications using GSSAPI and connection reuse are at risk.

Recommendation

Update libcurl to version 8.0.0 or later. If not possible, do not reuse connections after changing CURLOPT_GSSAPI_DELEGATION.

Other vulnerabilities in libcurl

See all
Original NVD description (English source)

An authentication bypass vulnerability exists libcurl <8.0.0 in the connection reuse feature which can reuse previously established connections with incorrect user permissions due to a failure to check for changes in the CURLOPT_GSSAPI_DELEGATION option. This vulnerability affects krb5/kerberos/negotiate/GSSAPI transfers and could potentially result in unauthorized access to sensitive information. The safest option is to not reuse connections if the CURLOPT_GSSAPI_DELEGATION option has been changed.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS