CVE Catalog

CVE-2023-23919

HighCVSS 7.5
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

High risk
2.21%

82th percentile - higher than 82% of all known CVEs

Summary

A cryptographic vulnerability exists in Node.js <19.2.0, <18.14.1, <16.19.1, <14.21.3 where in some cases the OpenSSL error stack is not cleared after operations that may set it. This may lead to false positive errors during subsequent cryptographic operations on the same thread.

Risk Assessment

False cryptographic errors could be used to cause a denial of service in Node.js-based applications.

Recommendation

Upgrade Node.js to version 19.2.0, 18.14.1, 16.19.1, 14.21.3 or later.

Other vulnerabilities in Node.js

See all
Original NVD description (English source)

A cryptographic vulnerability exists in Node.js <19.2.0, <18.14.1, <16.19.1, <14.21.3 that in some cases did does not clear the OpenSSL error stack after operations that may set it. This may lead to false positive errors during subsequent cryptographic operations that happen to be on the same thread. This in turn could be used to cause a denial of service.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS