CVE Catalog

CVE-2023-23918

HighCVSS 7.5
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

High risk
2.02%

81th percentile - higher than 81% of all known CVEs

Summary

A privilege escalation vulnerability exists in Node.js <19.6.1, <18.14.1, <16.19.1 and <14.21.3 that makes it possible to bypass the experimental Permissions feature and access non-authorized modules using process.mainModule.require(). This only affects users who enabled the experimental permissions option with --experimental-policy.

Risk Assessment

An attacker can bypass the permissions mechanism and access modules they should not have access to, potentially leading to privilege escalation within the application.

Recommendation

Upgrade Node.js to version 19.6.1, 18.14.1, 16.19.1, 14.21.3 or later.

Other vulnerabilities in Node.js

See all
Original NVD description (English source)

A privilege escalation vulnerability exists in Node.js <19.6.1, <18.14.1, <16.19.1 and <14.21.3 that made it possible to bypass the experimental Permissions (https://nodejs.org/api/permissions.html) feature in Node.js and access non authorized modules by using process.mainModule.require(). This only affects users who had enabled the experimental permissions option with --experimental-policy.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS