CVE Catalog

CVE-2023-23548

MediumCVSS 5.4
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.41%

34th percentile - higher than 34% of all known CVEs

Summary

Checkmk business intelligence is affected by reflected XSS in versions <2.2.0p8, <2.1.0p32, <2.0.0p38, and <=1.6.0p30. The vulnerability allows injection of a malicious script that is reflected to the user's browser.

Risk Assessment

An attacker can execute a malicious script in the context of a Checkmk user's session, potentially leading to credential theft or unauthorized operations in the monitoring system.

Recommendation

Update Checkmk to 2.2.0p8, 2.1.0p32, 2.0.0p38 or later (above 1.6.0p30) and verify proper input encoding in the business intelligence module.

Other vulnerabilities in Checkmk

See all
Original NVD description (English source)

Reflected XSS in business intelligence in Checkmk <2.2.0p8, <2.1.0p32, <2.0.0p38, <=1.6.0p30.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS