CVE Catalog

CVE-2023-0251

HighCVSS 7.8
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.30%

22th percentile - higher than 22% of all known CVEs

Summary

Delta Electronics DIAScreen versions 1.2.1.23 and prior are vulnerable to a buffer overflow due to improper restrictions of memory operations. This could allow an attacker to remotely execute arbitrary code.

Risk Assessment

Remote code execution in an engineering application for controllers can lead to workstation takeover or manipulation of industrial device configurations. The risk is significant in OT environments where DIAScreen is used to program controllers.

Recommendation

Update DIAScreen to a version later than 1.2.1.23 and restrict network access to hosts running this software. Apply OT/IT network segmentation and least-privilege principles.

Other vulnerabilities in Delta Electronics DIAScreen

See all
Original NVD description (English source)

Delta Electronics DIAScreen versions 1.2.1.23 and prior are vulnerable to a buffer overflow through improper restrictions of operations within memory, which could allow an attacker to remotely execute arbitrary code.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS