CVE Catalog

CVE-2022-47924

MediumCVSS 6.5
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.26%

17th percentile - higher than 17% of all known CVEs

Summary

A highly privileged attacker may pass crafted arguments to the validate function of csaf-validator-lib in a locally installed Secvisogram in versions < 0.1.0. This can result in arbitrary code execution and DoS once the user triggers validation.

Risk Assessment

This may lead to execution of malicious code in the application context and to denial of service, potentially disrupting system operation.

Recommendation

Update csaf-validator-lib to version 0.1.0 or later. Restrict access to Secvisogram to trusted, highly privileged users only.

Related vulnerabilities

Original NVD description (English source)

An high privileged attacker may pass crafted arguments to the validate function of csaf-validator-lib of a locally installed Secvisogram in versions < 0.1.0 wich can result in arbitrary code execution and DoS once the users triggers the validation.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS