CVE Catalog

CVE-2022-3016

HighCVSS 7.8
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.53%

45th percentile - higher than 45% of all known CVEs

Summary

A use-after-free vulnerability in the Vim editor prior to version 9.0.0286. The memory management flaw may lead to undefined behavior or application crashes.

Risk Assessment

An attacker able to supply a crafted file or input to Vim may trigger a crash or potentially execute malicious code in the context of the editor user.

Recommendation

Update Vim to version 9.0.0286 or later and avoid opening untrusted files in vulnerable versions.

Other vulnerabilities in Vim

See all
Original NVD description (English source)

Use After Free in GitHub repository vim/vim prior to 9.0.0286.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS