Actively exploited in the wild
Apache CouchDB Insecure Default Initialization of Resource Vulnerability
Apache - CouchDB · Listed in the CISA KEV since 2022-08-25. This indicates confirmed attacks in production environments.
Required action: Apply updates per vendor instructions.
CVE-2022-24706
CriticalCVSS 9.8KEVSummary
In Apache CouchDB prior to 3.2.2, an attacker can access an improperly secured default installation without authenticating and gain admin privileges. The documentation has always recommended proper security measures, including a firewall.
Risk Assessment
An unauthenticated attacker can gain full control of the CouchDB database, potentially leading to data confidentiality and integrity compromise.
Recommendation
Update Apache CouchDB to version 3.2.2 or later and apply recommended security measures such as firewall and authentication.
Other vulnerabilities in Apache CouchDB
See all- CVE-2026-90800High
Missing authorisation checks in chttpd in Apache CouchDB 3.5.2 and below on all platforms allows any request to read the full contents of a prefixed _user or _replicator database via an unauthorised API endpoint. The use of prefixed system databases is very rare. Users are recommended to upgrade to version 3.5.3, which fixes this issue.
- CVE-2026-90799Low
Unsafe binary deserialisation in chttpd in Apache CouchDB 3.5.2 and below on all platforms allows an authenticated user to cause a denial of service via memory exhaustion. Users are recommended to upgrade to version 3.5.3, which fixes this issue.
- CVE-2026-90798Low
A missing circuit-breaker in the replicator in Apache CouchDB 3.5.2 and below on all platforms allows the owner of a replication source or target to cause a denial of service via creating an infinite HTTP redirect loop. Users are recommended to upgrade to version 3.5.3, which fixes this issue.
- CVE-2026-90797High
Apache CouchDB 3.5.2 and below contains an unlimited gzip decompression routine in chttpd. Any remote client can cause a denial of service via memory exhaustion.
- CVE-2026-107755Medium
Apache CouchDB 3.5.2 and below insufficiently filters credentials in the _replicator database. An authenticated user can read replication credentials of other users' replications, not just their own.
- CVE-2017-12636High
CouchDB administrative users can configure the database server via HTTP(S), allowing them to specify paths for operating system-level binaries. This enables the CouchDB user to execute arbitrary shell commands, including downloading and executing scripts from the public internet.
- CVE-2026-86471Critical
An unvalidated runtime configuration value in Apache CouchDB 3.5.2 and below on all platforms allows a CouchDB server admin to run arbitrary shell commands as the CouchDB operating system user.
- CVE-2017-12635Critical
In Apache CouchDB before version 1.7.0 and 2.x before version 2.1.1, a vulnerability allows submitting _users documents with duplicate 'roles' keys, which can lead to non-admin users being granted admin privileges.
Original NVD description (English source)
In Apache CouchDB prior to 3.2.2, an attacker can access an improperly secured default installation without authenticating and gain admin privileges. The CouchDB documentation has always made recommendations for properly securing an installation, including recommending using a firewall in front of all CouchDB installations.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

