CVE Catalog

CVE-2022-1619

HighCVSS 7.8
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

High risk
2.54%

85th percentile - higher than 85% of all known CVEs

Summary

Heap-based Buffer Overflow in function cmdline_erase_chars in GitHub repository vim/vim prior to 8.2.4899. This vulnerabilities are capable of crashing software, modify memory, and possible remote execution

Risk Assessment

An attacker can crash the Vim editor or execute arbitrary code in the user's context. This may lead to data loss or system compromise.

Recommendation

Update Vim to version 8.2.4899 or later. Avoid opening untrusted files in vulnerable versions of the editor.

Other vulnerabilities in Vim

See all
Original NVD description (English source)

Heap-based Buffer Overflow in function cmdline_erase_chars in GitHub repository vim/vim prior to 8.2.4899. This vulnerabilities are capable of crashing software, modify memory, and possible remote execution

Vulnerability data from NVD (NIST) · CISA KEV · EPSS