CVE Catalog

CVE-2021-20305

HighCVSS 8.1
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

High risk
1.69%

77th percentile - higher than 77% of all known CVEs

Summary

A flaw was found in Nettle in versions before 3.7.2, where several Nettle signature verification functions (GOST DSA, EDDSA & ECDSA) result in the Elliptic Curve Cryptography point (ECC) multiply function being called with out-of-range scalers, possibly resulting in incorrect results. This flaw allows an attacker to force an invalid signature, causing an assertion failure or possible validation. The highest threat to this vulnerability is to confidentiality, integrity, as well as system availability.

Risk Assessment

The vulnerability may allow an attacker to bypass signature verification or cause a crash, threatening confidentiality, integrity, and availability of systems using Nettle.

Recommendation

Upgrade Nettle to version 3.7.2 or later and verify signature verification correctness in applications using this library.

Other vulnerabilities in Nettle

See all
Original NVD description (English source)

A flaw was found in Nettle in versions before 3.7.2, where several Nettle signature verification functions (GOST DSA, EDDSA & ECDSA) result in the Elliptic Curve Cryptography point (ECC) multiply function being called with out-of-range scalers, possibly resulting in incorrect results. This flaw allows an attacker to force an invalid signature, causing an assertion failure or possible validation. The highest threat to this vulnerability is to confidentiality, integrity, as well as system availability.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS