CVE-2019-16777
HighCVSS 7.7Summary
The npm CLI versions prior to 6.13.4 are vulnerable to Arbitrary File Overwrite. It fails to prevent existing globally-installed binaries from being overwritten by other package installations, even with the --ignore-scripts option.
Risk Assessment
This may allow an attacker to overwrite trusted executables and execute malicious code. The risk affects development environments using npm.
Recommendation
Update npm CLI to version 6.13.4 or later. Avoid global installations from untrusted sources.
Other vulnerabilities in npm CLI
See all- CVE-2020-15095Medium
Versions of the npm CLI prior to 6.14.6 are vulnerable to an information exposure vulnerability through log files. The CLI supports URLs like "<protocol>://[<user>[:<password>]@]<hostname>[:<port>][:][/]<path>". The password value is not redacted and is printed to stdout and also to any generated log files.
- CVE-2019-16776High
Versions of the npm CLI prior to 6.13.3 are vulnerable to an Arbitrary File Write. Through the bin field in package.json, a package publisher can access folders outside the intended node_modules directory and modify arbitrary files on a user's system during installation. This vulnerability bypasses the --ignore-scripts install option.
- CVE-2019-16775High
npm CLI versions prior to 6.13.3 are vulnerable to Arbitrary File Write. Packages can create symlinks to files outside node_modules via the bin field in package.json during installation, bypassing the --ignore-scripts option.
- CVE-2016-3956High
The CLI in npm before 2.15.1 and 3.x before 3.8.3, as used in Node.js 0.10 before 0.10.44, 0.12 before 0.12.13, 4 before 4.4.2, and 5 before 5.10.0, includes bearer tokens with arbitrary requests. This allows remote HTTP servers to obtain sensitive information by reading Authorization headers.
- CVE-2026-0775High
A vulnerability in npm cli allows local attackers to escalate privileges due to incorrect permission assignment when loading modules from an unsecured location. This can lead to arbitrary code execution in the context of a target user.
Original NVD description (English source)
Versions of the npm CLI prior to 6.13.4 are vulnerable to an Arbitrary File Overwrite. It fails to prevent existing globally-installed binaries to be overwritten by other package installations. For example, if a package was installed globally and created a serve binary, any subsequent installs of packages that also create a serve binary would overwrite the previous serve binary. This behavior is still allowed in local installations and also through install scripts. This vulnerability bypasses a user using the --ignore-scripts install option.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

