CVE Catalog

CVE-2011-10038

MediumCVSS 5.4
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.47%

39th percentile - higher than 39% of all known CVEs

Summary

Nagios XI versions prior to 2011R1.9 are vulnerable to cross-site scripting (XSS) via the recurring downtime script of the web interface. Insufficient validation or escaping of user-supplied input may allow an attacker to inject and execute arbitrary script in the context of a victim's browser.

Risk Assessment

An attacker could execute arbitrary JavaScript in the browser of a logged-in Nagios XI user, potentially leading to session theft, account takeover, or modification of monitoring configuration.

Recommendation

Update Nagios XI to version 2011R1.9 or later. Additionally, consider implementing security headers (CSP) and input filtering.

Other vulnerabilities in Nagios XI

See all
Original NVD description (English source)

Nagios XI versions prior to 2011R1.9 are vulnerable to cross-site scripting (XSS) via the recurring downtime script of the web interface. Insufficient validation or escaping of user-supplied input may allow an attacker to inject and execute arbitrary script in the context of a victim's browser.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS