CVE Vulnerability Catalog

Translated CVE descriptions from NVD NIST - in English

Browse vulnerabilities by package

CISA KEV catalog updated: (v2026.11.04)

Weekly CVE digest

One email a week with newly published vulnerabilities worth knowing about. No account needed.

This digest covers new vulnerabilities in general, not your servers. If you want to know which of them actually run in your infrastructure, that is what Secvalis does: it scans your machines and reports only what concerns them.

I agree to receive the weekly CVE digest at the address above. I can withdraw this consent at any time using the link in the footer of every message.

CVE-2026-18394
High

In Strands Agents Tools before 0.8.2, incorrect authorization in the http_request tool may allow remote attackers to obtain credentials configured via HTTP_REQUEST_TOKEN_CONFIG by influencing the LLM to route requests through attacker-controlled proxy infrastructure.

CVE-2026-53505
High

Thumbor before 7.8.0 in the filters:proportion(<value>) filter does not enforce an upper bound on <value> and runs in the post-transform phase. An attacker can trigger extremely large resizes (CPU/memory exhaustion) and cause denial of service.

CVE-2026-53504
High

Thumbor before 7.8.0 in the convolution filter uses a regular expression that performs exponential backtracking on crafted repeated numeric input, allowing a URL request to exhaust processing time.

CVE-2026-53503
High

Thumbor before 7.8.0 in the filters:convolution(<matrix>, <columns>, <should_normalize>) filter passes the user-controlled <columns> value to a C extension where it is used as a divisor without validating columns > 0. When columns=0, the C code triggers undefined behavior; on x86_64 this reliably results in a fatal divide-by-zero trap (SIGFPE) and crashes the Thumbor process, causing a remote denial of service.

CVE-2026-53502
High

Thumbor before 7.8.0 in file_loader decodes percent-encoded path segments after its root-boundary validation, allowing traversal outside FILE_LOADER_ROOT_PATH through watermark or frame filter input.

CVE-2026-53501
High

Thumbor before 7.8.0 in HMAC validation uses Python's .replace() to remove the signature from the URL before validation. Since .replace() removes all occurrences of the substring, an attacker can insert the same signature multiple times in the URL and manipulate the final URL used for validation, enabling loading images from unintended domains or paths.

CVE-2026-53500
High

Thumbor before 7.8.0 in the ALLOWED_SOURCES configuration passes plain strings to re.match() without escaping dots, so a hostname differing at dot positions can match the allowlist.

CVE-2026-18481
High

Stored XSS in participant URL handling in AWS Ops Wheel before PR #168. Allows an authenticated remote user to steal session tokens and escalate to full administrative control via a crafted participant_url with a dangerous URI scheme.

CVE-2026-55100
High

In hashi-vault-js before 0.5.2, src/Vault.js concatenates unencoded identifiers into Vault request paths and query strings without encodeURIComponent() and URLSearchParams, allowing path traversal and query parameter injection.

CVE-2026-54737
High

In @phun-ky/defaults-deep before 2.0.5, defaultsDeep() recursively merges user-supplied objects without filtering proto, constructor, and prototype, allowing properties to be written to Object.prototype (prototype pollution).

CVE-2026-54729
High

In DSSRF before 1.0.5, is_url_safe can treat localhost as safe when DNS resolver 1.1.1.1 returns NXDOMAIN because dns.resolve4 yields no address and no dns.lookup fallback occurs, allowing SSRF.

CVE-2026-52856
High

Wings, the server control plane for Pterodactyl, prior to version 1.13.0 contains a vulnerability causing a Go panic due to a malformed packet received during the SFTP connection handshake. This issue is fixed in version 1.13.0.

CVE-2026-18141
High

In the aap-gateway component of Ansible Automation Platform's Event-Driven Ansible (EDA), a vulnerability allows an unauthenticated remote attacker to bypass mTLS authentication for event streams. The attacker can manipulate the event stream URL and forge the HTTP Subject header, while the system inadvertently discloses the expected certificate subject in error messages.

CVE-2026-17347
HighEPSS 53%

In pgAdmin 4 from version 7.2 before 9.17, the MASTER_PASSWORD_HOOK setting allowed shell command injection via a username containing shell metacharacters (e.g., ';', '$()', backticks). The username from external auth sources (OAuth, Kerberos) could be used to execute arbitrary commands as the pgAdmin service account.

CVE-2026-17346
High

A vulnerability in pgAdmin 4 allows SQL injection via improper escaping of object names in query templates. A low-privileged user can create an object with an apostrophe in its name, which when another user opens the Statistics or Dependencies tab leads to arbitrary SQL execution in the database session.

CVE-2026-18446
High

The fast-uri library before versions 4.1.2, 3.1.5, and 2.4.4 incorrectly parses URIs when a backslash is used instead of a double forward slash. Node.js treats backslash as interchangeable with forward slash, leading to differences in host parsing. Applications using fast-uri for host-based policy enforcement can be steered to an unintended host.

CVE-2026-10685
High

In the Zephyr Bluetooth GATT client, in the gatt_write_ccc_rsp() function, a use-after-free vulnerability exists. Upon receiving an ATT Error Response from a GATT server, the function calls the notify(NULL) callback signaling subscription termination, then calls the subscribe() callback on the already freed structure, leading to use-after-free.

CVE-2026-18358
High

In gnome-remote-desktop as shipped in Red Hat Enterprise Linux, when the daemon runs in system mode with RDP enabled, the incoming connection handler bypasses the connection throttler. This allows an unauthenticated remote attacker to open many parallel pre-authentication connections, exhausting resources and preventing legitimate users from establishing RDP sessions.

CVE-2026-46593
High

A SQL injection vulnerability has been identified in PHP Jabbers - PHP Poll Script in the pjAdminPolls.controller.php endpoint. An authenticated attacker can manipulate input data, leading to unauthorized SQL queries. This issue was fixed in version 4.1.

CVE-2025-67650
High

An authenticated SQL injection vulnerability has been identified in multiple PHP Jabbers scripts. An authenticated user can manipulate parameters responsible for sorting functions, leading to unauthorized SQL queries. This issue was fixed in the versions specified in the affected products list.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS