CVE Vulnerability Catalog

Translated CVE descriptions from NVD NIST - in English

Browse vulnerabilities by package

CISA KEV catalog updated: (v2026.11.06)

Weekly CVE digest

One email a week with newly published vulnerabilities worth knowing about. No account needed.

This digest covers new vulnerabilities in general, not your servers. If you want to know which of them actually run in your infrastructure, that is what Secvalis does: it scans your machines and reports only what concerns them.

I agree to receive the weekly CVE digest at the address above. I can withdraw this consent at any time using the link in the footer of every message.

CVE-2024-7042
Low
—

Podatność w klasie GraphCypherQAChain w wersjach 0.2.5 i wcześniejszych langchain-ai/langchainjs umożliwia wstrzykiwanie poleceń, co prowadzi do możliwości SQL injection. Umożliwia to nieautoryzowaną manipulację danymi oraz ich wyciek.

CVE-2019-6988
Low
—

W OpenJPEG 2.3.0 odkryto problem, który pozwala zdalnym atakującym na wywołanie odmowy usługi poprzez próbę nadmiernej alokacji pamięci w funkcji opj_calloc. Problem ten występuje podczas wywołania z opj_tcd_init_tile.

CVE-2026-2391
Low
—

Opcja `arrayLimit` w bibliotece qs nie egzekwuje limitów dla wartości oddzielonych przecinkami, gdy `comma: true` jest włączone, co pozwala atakującym na spowodowanie odmowy usługi poprzez wyczerpanie pamięci. Jest to obejście egzekwowania limitu tablicy, podobne do obejścia notacji nawiasowej omówionego w GHSA-6.

CVE-2019-9543
Low
—

W Poppler 0.74.0 odkryto problem związany z rekurencyjnym wywołaniem funkcji w JBIG2Stream::readGenericBitmap(). Może to zostać wywołane przez wysłanie spreparowanego pliku PDF do binarnego programu pdfseparate, co prowadzi do awarii systemu (błąd segmentacji).

CVE-2026-42040
Low
—

Axios to klient HTTP oparty na obietnicach dla przeglądarki i Node.js. W wersjach przed 1.15.1 i 0.31.1 funkcja encode() w pliku lib/helpers/AxiosURLSearchParams.js zawiera mapowanie znaków, które odwraca bezpieczne kodowanie procentowe bajtów null.

CVE-2024-25269
Low
—

libheif w wersjach do 1.17.6 zawiera wyciek pamięci w funkcji JpegEncoder::Encode. Ta wada umożliwia atakującemu przeprowadzenie ataku typu denial of service.

CVE-2026-1703
Low
—

Podczas instalacji i ekstrakcji złośliwie skonstruowanego archiwum wheel przez pip, pliki mogą być wydobywane poza katalog instalacyjny. Przechodzenie po ścieżkach jest ograniczone do prefiksów katalogu instalacyjnego, co uniemożliwia wtypowanie lub nadpisanie plików wykonywalnych w typowych sytuacjach.

CVE-2025-69420
Low
—

W kodzie weryfikacji odpowiedzi TimeStamp występuje podatność typu confusion, w której członek unii ASN1_TYPE jest dostępny bez wcześniejszej walidacji typu. Może to prowadzić do dereferencji nieprawidłowego lub NULL wskaźnika podczas przetwarzania źle sformatowanego pliku odpowiedzi TimeStamp.

CVE-2022-1615
Low
—

W Samba, funkcja GnuTLS gnutls_rnd() może zakończyć się niepowodzeniem, co prowadzi do generowania przewidywalnych wartości losowych. To może wpłynąć na bezpieczeństwo aplikacji korzystających z tej funkcji.

CVE-2022-32743
Low
—

Samba nie weryfikuje poprawności atrybutu Validated-DNS-Host-Name dla atrybutu dNSHostName, co może pozwolić nieuprzywilejowanym użytkownikom na jego zapisanie.

CVE-2026-3455
Low
—

Wersje pakietu mailparser przed 3.9.3 są podatne na ataki Cross-site Scripting (XSS) poprzez funkcję textToHtml() z powodu niewłaściwego oczyszczania adresów URL w treści e-maili. Atakujący może wykonać dowolne skrypty w przeglądarkach ofiar, dodając dodatkowy znak cudzysłowu " do adresu URL.

GHSA-537c-gmf6-5ccf
High
—

The wheels of pyca/cryptography include a statically linked copy of OpenSSL. The versions of OpenSSL included in wheels prior to cryptograph 48.01 are vulnerable to a security issue.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS