CVE Vulnerability Catalog
Translated CVE descriptions from NVD NIST - in English
Browse vulnerabilities by packageCISA KEV catalog updated: (v2026.11.04)
Weekly CVE digest
One email a week with newly published vulnerabilities worth knowing about. No account needed.
This digest covers new vulnerabilities in general, not your servers. If you want to know which of them actually run in your infrastructure, that is what Secvalis does: it scans your machines and reports only what concerns them.
IBM i 7.6, 7.5, 7.4, and 7.3 is vulnerable to privilege escalation via Navigator for i. An authenticated user could elevate privileges to a root user to execute commands.
IBM WebSphere Application Server - Liberty 17.0.0.3 through 26.0.0.8 is vulnerable to a privilege escalation when using Liberty collectives.
IBM i 7.6, 7.5, 7.4, and 7.3 could allow a remote authenticated attacker to obtain sensitive information and compromise system integrity due to an XML injection flaw.
IBM i 7.6, 7.5, 7.4, and 7.3 could allow a remote authenticated attacker to bypass security restrictions due to unsafe reflection.
Fujitsu Research's OneCompression library before 1.2.1 contains an unsafe deserialization vulnerability that allows attackers to execute arbitrary code by supplying a crafted model.pt checkpoint file. The load_quantized_model_pt() function unconditionally calls torch.load with weights_only=False, invoking Python's pickle machinery during deserialization.
Semaphore UI is a web interface for managing DevOps tools. Prior to 2.18.19 and from 2.19.0-alpha3 until 2.19.5-beta5, ProjectMiddleware and GetProjectOrGlobalRoleBySlug allow a project manager to use POST /api/project/{id}/roles to create a custom manager role with permission bitmask 15, overriding the built-in manager permissions and granting CanUpdateProject and CanManageProjectUsers owner capabilities. This issue is fixed in versions 2.18.19 and 2.19.5-beta5.
Semaphore UI before version 2.18.21 has a CSRF vulnerability in the /api/users/{id}/password endpoint, allowing an unauthenticated attacker to change an administrator's or another user's password after user interaction. No CSRF protection or current-password confirmation is present.
An unauthenticated attacker may cause untrusted package content to be cached under specific conditions, potentially affecting artifact integrity and availability.
Apache Airflow's Backfill API authorized a request against a Dag id supplied by the caller whenever the `backfill_id` path segment failed to parse. The authorization dependency parsed it with `int()` while the route handler parsed it as pydantic's `NonNegativeInt`, which accepts values `int()` rejects (`1.0` coerces to `1`); FastAPI resolves dependencies before endpoint validation, so the two acted on different Dags. An authenticated user holding edit permission on any single Dag could therefore read, pause and cancel backfills belonging to any other Dag, including moving another Dag's queued runs to `failed`. No non-default configuration is required and backfill ids are sequential, so finding a target is trivial. Users are advised to upgrade to apache-airflow 3.3.1 or later, which parses the backfill id with the same type the routes declare.
A holder of a valid integration credential may impersonate other users under specific conditions.
Apache Airflow's Task SDK rebuilt a `Callback` object from serialized data by re-running its constructor, which imports the module named by the stored callback path. Because `SyncCallback` is itself an Airflow class it passes the default `allowed_deserialization_classes` allow-list, so tightening that setting does not help. A Dag author — who controls a task instance's `next_kwargs` through the task execution API — can therefore cause an arbitrary module to be imported inside the scheduler process, when the scheduler's `awaiting_input` timeout sweep deserializes that value. No non-default configuration is required; the sweep runs unconditionally. Versions before 3.3.0 are not affected: the class existed, but the scheduler sweep that reaches it did not. This is a separate code path from CVE-2026-58076 and CVE-2026-67260, which cover different gadgets reaching deserialization — applying either of those fixes does not address this one. Users are advised to upgrade to apache-airflow 3.3.1 or later.
Apache Airflow 3.3.0 has a vulnerability in the human-in-the-loop task handling, where deserialization of next_kwargs without an allow-list allows a DAG author to import arbitrary modules and instantiate objects in the scheduler process or terminate the scheduler job. Upgrade to 3.3.1 or later is required.
WhatsUp Gold before version 2026.0.2 has a vulnerability allowing an unauthenticated remote attacker to execute arbitrary code in the context of the IIS application service account.
WhatsUp Gold before version 2026.0.2 has a vulnerability allowing an authenticated attacker to bypass frontend controls and inject persistent script content.
Apache Airflow's serialization layer reconstructs exception nodes by calling `import_string()` on a class name from the serialized blob and instantiating it with arguments from the same blob, with no restriction on what can be imported. A Dag author can place a value in `executor_config` that causes an arbitrary callable to be imported and invoked, e.g., `subprocess.check_output` or `builtins.eval`. The code runs in the Scheduler and API server, which per Airflow's security model must never execute Dag-author code.
Eclipse RDF4J has insufficient restriction of XML External Entity (XXE) processing in several XML parser entry points, allowing DOCTYPE declarations, external entity references, and external DTD loading. The issue is fixed in version 5.3.2.
Vulnerability-Lookup has an authentication weakness in account activation and password recovery, where tokens are reusable and not purpose-bound. An attacker who obtains a valid link can repeatedly change the password and take control of the account.
Seerr before version 3.4.0 has a vulnerability in ImageProxy where ETag and Content-Type headers are used to build cache filenames, allowing path traversal and file overwrite, including /app/dist/index.js, leading to code execution after container restart.
RustFS before version 1.0.0-beta.12 has incorrect evaluation of ForAllValues: and ForAnyValue: qualifiers with negated string operators, potentially granting access to excluded principals or making Deny rules ineffective.
RustFS before version 1.0.0-beta.12 has a vulnerability where get_condition_values folds attacker-controlled request headers into identity-based condition keys such as userid, username, principaltype, groups, versionid, signatureversion, jwt:, and ldap:. This allows authenticated callers to satisfy identity-based policy conditions.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

