CVE Vulnerability Catalog

Translated CVE descriptions from NVD NIST - in English

Browse vulnerabilities by package

CISA KEV catalog updated: (v2026.10.30)

Weekly CVE digest

One email a week with newly published vulnerabilities worth knowing about. No account needed.

This digest covers new vulnerabilities in general, not your servers. If you want to know which of them actually run in your infrastructure, that is what Secvalis does: it scans your machines and reports only what concerns them.

I agree to receive the weekly CVE digest at the address above. I can withdraw this consent at any time using the link in the footer of every message.

CVE-2019-6462
Low
—

W wersji 1.16.0 biblioteki cairo odkryto problem związany z nieskończoną pętlą w funkcji _arc_error_normalized w pliku cairo-arc.c, która jest powiązana z _arc_max_angle_for_tolerance_normalized.

CVE-2017-7475
Low
—

Wersja 1.15.4 biblioteki Cairo jest podatna na dereferencję wskaźnika NULL w związku z funkcjami FT_Load_Glyph i FT_Render_Glyph, co prowadzi do awarii aplikacji.

CVE-2025-50422
Medium
—

Cairo w wersjach do 1.18.4, używany w Poppler do wersji 25.08.0, zawiera błąd asercji 'unscaled->face == NULL' w funkcji _cairo_ft_unscaled_font_fini w pliku cairo-ft-font.c.

CVE-2025-1632
Low
—

W bibliotece libarchive do wersji 3.7.7 odkryto podatność, która została sklasyfikowana jako problematyczna. Dotyczy ona funkcji list w pliku bsdunzip.c i prowadzi do dereferencji wskaźnika null.

CVE-2025-68276
Medium
—

Avahi to system, który ułatwia odkrywanie usług w lokalnej sieci za pomocą protokołu mDNS/DNS-SD. W wersjach 0.9-rc2 i wcześniejszych, nieuprzywilejowani lokalni użytkownicy mogą spowodować awarię avahi-daemon, tworząc przeglądarki rekordów z ustawioną flagą AVAHI_LOOKUP_USE_WIDE_AREA przez D-Bus.

CVE-2019-6988
Low
—

W OpenJPEG 2.3.0 odkryto problem, który pozwala zdalnym atakującym na wywołanie odmowy usługi poprzez próbę nadmiernej alokacji pamięci w funkcji opj_calloc. Problem ten występuje podczas wywołania z opj_tcd_init_tile.

CVE-2017-9814
Low
—

W pliku cairo-truetype-subset.c w wersji cairo 1.15.6 i wcześniejszych występuje podatność, która pozwala zdalnym atakującym na spowodowanie odmowy usługi (odczyt poza zakresem) z powodu niewłaściwego obsługiwania nieoczekiwanego wywołania malloc(0).

CVE-2022-32743
Low
—

Samba nie weryfikuje poprawności atrybutu Validated-DNS-Host-Name dla atrybutu dNSHostName, co może pozwolić nieuprzywilejowanym użytkownikom na jego zapisanie.

CVE-2025-61143
Low
—

W libtiff w wersjach do 4.7.1 odkryto podatność na dereferencję wskaźnika NULL w komponencie libtiff/tif_open.c. Może to prowadzić do nieoczekiwanego zachowania aplikacji.

CVE-2026-27448
Low
—

W bibliotece pyOpenSSL, od wersji 0.14.0 do przed wersją 26.0.0, występuje podatność, która pozwala na zaakceptowanie połączenia, jeśli użytkownik dostarczył callback do `set_tlsext_servername_callback`, który zgłosił nieobsługiwany wyjątek.

CVE-2019-9543
Low
—

W Poppler 0.74.0 odkryto problem związany z rekurencyjnym wywołaniem funkcji w JBIG2Stream::readGenericBitmap(). Może to zostać wywołane przez wysłanie spreparowanego pliku PDF do binarnego programu pdfseparate, co prowadzi do awarii systemu (błąd segmentacji).

CVE-2017-7189
Low
—

W PHP 7.x przed 2017-03-07 występuje błąd w analizie wywołań fsockopen, który może prowadzić do nieprawidłowego interpretowania adresów i portów. Na przykład, wywołanie fsockopen('127.0.0.1:80', 443) może być zinterpretowane jako 127.0.0.1:80:443, co później jest skracane do 127.0.0.1:80.

CVE-2022-1615
Low
—

W Samba, funkcja GnuTLS gnutls_rnd() może zakończyć się niepowodzeniem, co prowadzi do generowania przewidywalnych wartości losowych. To może wpłynąć na bezpieczeństwo aplikacji korzystających z tej funkcji.

CVE-2026-42040
Low
—

Axios to klient HTTP oparty na obietnicach dla przeglądarki i Node.js. W wersjach przed 1.15.1 i 0.31.1 funkcja encode() w pliku lib/helpers/AxiosURLSearchParams.js zawiera mapowanie znaków, które odwraca bezpieczne kodowanie procentowe bajtów null.

GHSA-537c-gmf6-5ccf
High
—

The wheels of pyca/cryptography include a statically linked copy of OpenSSL. The versions of OpenSSL included in wheels prior to cryptograph 48.01 are vulnerable to a security issue.

CVE-2026-3455
Low
—

Wersje pakietu mailparser przed 3.9.3 są podatne na ataki Cross-site Scripting (XSS) poprzez funkcję textToHtml() z powodu niewłaściwego oczyszczania adresów URL w treści e-maili. Atakujący może wykonać dowolne skrypty w przeglądarkach ofiar, dodając dodatkowy znak cudzysłowu " do adresu URL.

CVE-2026-18724
Medium
—

The iscsi-initiator-utils package version 6.2.1.11-0.git4b3e853.el10 has a stack buffer overflow vulnerability in idbm_recinfo_config. A malicious iSCSI target can inject an extra configuration line into a persisted node record via a crafted SendTargets TargetName, later causing a stack buffer overflow.

CVE-2024-52006
High
—

Git defines a line-based protocol used to exchange information between Git and Git credential helpers. Some ecosystems (most likely those using this protocol) may be vulnerable to attacks related to this protocol.

CVE-2024-45338
High
—

An attacker can craft an input to the Parse functions that would be processed non-linearly with respect to its length, resulting in extremely slow parsing. This could cause a denial of service.

GHSA-6v7p-g79w-8964
High
—

Repeated use of the Unpacker after an error occurs may cause the process to crash with a SEGV. If the Unpacker is used repeatedly to unpack untrusted input from external sources, it may be vulnerable to a DoS attack.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS