CVE Vulnerability Catalog

Translated CVE descriptions from NVD NIST - in English

Browse vulnerabilities by package

CISA KEV catalog updated: (v2026.10.30)

Weekly CVE digest

One email a week with newly published vulnerabilities worth knowing about. No account needed.

This digest covers new vulnerabilities in general, not your servers. If you want to know which of them actually run in your infrastructure, that is what Secvalis does: it scans your machines and reports only what concerns them.

I agree to receive the weekly CVE digest at the address above. I can withdraw this consent at any time using the link in the footer of every message.

CVE-2026-94650
High

Uncontrolled recursion vulnerability in Apache Thrift c_glib bindings. Excessive recursion can lead to stack overflow and process crash. Affects versions before 0.25.0.

CVE-2026-94645
High

Vulnerability in Apache Thrift nodejs bindings involving improper validation of specified quantity in input and allocation of resources without limits. Affects versions before 0.25.0.

CVE-2026-94644
High

Allocation of resources without limits or throttling vulnerability in Apache Thrift PHP bindings. Lack of limits can lead to resource exhaustion. Affects versions before 0.25.0.

CVE-2026-94642
High

Uncaught exception vulnerability in Apache Thrift PHP bindings. An unhandled exception can lead to unexpected termination of the application. Affects versions before 0.25.0.

CVE-2026-94633
High

Vulnerability in Apache Thrift Dart bindings involving memory allocation with excessive size value and improper handling of length parameter inconsistency. Affects versions before 0.25.0.

CVE-2026-93926
High

Vulnerability in Apache Thrift THeaderTransport involving missing release of memory and resources after effective lifetime. Affects versions before 0.25.0.

CVE-2026-93925
High

A stack-based buffer overflow and incorrect bitwise shift of integer vulnerability exists in Apache Thrift C++ THeaderProtocol. This issue affects Apache Thrift versions before 0.25.0.

CVE-2026-91137
High

Improper validation of specified quantity in input, allocation of resources without limits or throttling, and excessive iteration vulnerability exists in Apache Thrift PHP bindings. This issue affects Apache Thrift versions before 0.25.0.

CVE-2026-91135
Critical

Heap-based buffer overflow vulnerability in Apache Thrift C++ THeaderTransport. When an application enables the ZLIB transform for the frames it sends, THeaderTransport::transform() copies the compressed frame into the write buffer without making sure it fits. Data that does not compress, such as content a remote peer supplied, grows under compression, so the copy writes past the end of the heap buffer, and for large frames it also reads past the end of the transform buffer.

CVE-2026-86326
High

An improper verification of cryptographic signature vulnerability exists in protocol gateways because the device does not properly verify the cryptographic authenticity of firmware images before installation. An attacker with high privileges and access to the firmware update interface could provide a specially crafted or modified firmware image, causing it to be installed on the device.

CVE-2026-86325
Critical

A stack-based buffer overflow vulnerability exists in protocol gateways' account management interface. The vulnerability is caused by insufficient length validation of the `account_name` parameter when processing account management requests. An attacker authenticated as a read-only user to the web management interface could supply a specially crafted account name that exceeds the size of the internal stack buffer, resulting in corruption of program execution flow.

CVE-2026-85494
High

Improper handling of length parameter inconsistency, uncaught exception, inefficient algorithmic complexity, memory allocation with excessive size value, and initialization of a resource with an insecure default vulnerability exists in Apache Thrift Python, Ruby, Erlang, Lua, Dart, JavaME, Perl, PHP and D language bindings. This issue affects Apache Thrift versions before 0.25.0.

CVE-2026-85493
High

An uncontrolled recursion vulnerability exists in Apache Thrift Dart and Java ME bindings. This issue affects Apache Thrift versions before 0.25.0.

CVE-2026-85483
Medium

The c_glib bindings of Apache Thrift are vulnerable to use of uninitialized resource and return of wrong status code. This issue affects Apache Thrift before 0.25.0.

CVE-2026-59668
Medium

The Repasat application is vulnerable to Cross-Site Scripting (XSS) via the 'nomTamano' parameter in the '/es/companysizebills/store' endpoint. Successful exploitation could allow an attacker to trick a user into executing arbitrary code in the victim's browser.

CVE-2026-59667
Medium

The Repasat application is vulnerable to Cross-Site Scripting (XSS) via the 'nomTamano' parameter in the '/es/companysizemployees/update' endpoint. Successful exploitation could allow an attacker to trick a user into executing arbitrary code in the victim's browser.

CVE-2026-59666
Medium

The Repasat application is vulnerable to Cross-Site Scripting (XSS) via the 'nomOrigen' parameter in the '/es/origins/store' endpoint. Successful exploitation could allow an attacker to trick a user into executing arbitrary code in the victim's browser.

CVE-2026-104606
Medium

A SQL injection vulnerability was discovered in itsourcecode Online Admission System 1.0 in the confirm.php file. Manipulation of the ID argument allows remote attacks. The exploit has been publicly released.

CVE-2026-97652
Medium

The WP Statistics plugin for WordPress up to version 14.16.14 is vulnerable to Reflected Cross-Site Scripting via the REQUEST_URI query parameter key. Insufficient input sanitization and output escaping allow unauthenticated attackers to inject scripts.

CVE-2026-95662
Medium

The Repasat application has a Cross-Site Scripting vulnerability in the nomCompetidor parameter at the /es/competitors/store endpoint. An attacker can trick a user into executing arbitrary code in the browser.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS