CVE Vulnerability Catalog
Translated CVE descriptions from NVD NIST - in English
Browse vulnerabilities by packageCISA KEV catalog updated: (v2026.10.28)
Weekly CVE digest
One email a week with newly published vulnerabilities worth knowing about. No account needed.
This digest covers new vulnerabilities in general, not your servers. If you want to know which of them actually run in your infrastructure, that is what Secvalis does: it scans your machines and reports only what concerns them.
Dell Container Storage Modules prior to version 1.18.0 contains a Use of Hard-coded Credentials vulnerability in CSM Authorization. An unauthenticated attacker with remote access could exploit this vulnerability to elevate privileges.
Dell Container Storage Modules prior to version 1.18.0 contains a Use of Hard-coded Credentials vulnerability in csm-docs. An unauthenticated attacker with remote access could exploit this vulnerability to disclose information.
A security flaw has been discovered in vllm-project vLLM up to 0.31.0, affecting the function get_token_bin_counts_and_mask in the file vllm/model_executor/layers/utils.py of the Penalty Handler component. Manipulation results in denial of service. Remote exploitation is possible, and the exploit has been publicly released.
A vulnerability was identified in Kusalkasilva Learning-Management-System up to version ffeb873f8803f1e9664384ff75000c7da45466d2, affecting an unknown function in the file search_class.php. Manipulation of the argument school_year leads to SQL injection. The attack can be launched remotely, and the exploit is publicly available.
openapi-python-client versions prior to 0.29.1 do not safely neutralize malicious OpenAPI document content before rendering in string, docstring, and f-string contexts in generated Python. The generated client can contain attacker-controlled Python that executes on import, affecting the importing environment's integrity.
i18next-http-backend prior to 4.0.2 allows attacker-controlled language or namespace values interpolated into a custom loadPath or addPath that begins directly with {{lng}} or {{ns}} to make colon-based input become an absolute URL or, in browsers, make a double-slash namespace become a protocol-relative URL. The resulting request can leave the intended origin and cause URL injection or server-side request forgery.
LangChain prior to 1.1.1 — @langchain/redis does not escape attacker-controlled values in structured RediSearch TAG filters and structured RediSearch TEXT filters, allowing injected RediSearch syntax to alter or broaden the generated search query. When an application uses an attacker-influenceable filter as a tenant or document-access boundary, the modified query can expose indexed documents outside the attacker's intended scope.
SimpleChat versions prior to 0.261.029 contain an XSS vulnerability in POST /api/group_documents/upload. An attacker with Owner, Admin, or DocumentManager privileges can persist a script that executes in the SimpleChat origin when another group member clicks Share, allowing access to victim-visible data and actions. This is fixed in version 0.261.029.
SimpleChat versions 0.261.003 and 0.261.027 contain an authorization ordering flaw in POST /api/user/plugins that allows an authenticated low-privileged user to bypass the _reject_non_admin_mcp_stdio check. This can lead to starting an attacker-selected OS process under the application service identity. This is fixed in version 0.261.031.
Kiota versions from 0.5.0 to 1.35.0 contain a vulnerability in the Java and PHP documentation-comment sanitizers that delete block-comment terminators rather than neutralizing them, allowing attacker-controlled OpenAPI text to be placed outside a comment. This can lead to code execution when the generated code is compiled and loaded. This is fixed in version 1.35.0.
Kiota, an OpenAPI-based HTTP client code generator, from 1.25.1 to 1.35.0 copies x-ai-capabilities.response_semantics.oauth_card_path from an OpenAPI description into a generated plugin manifest without validating it as a safe package-relative file reference. This can allow crossing the plugin-package boundary or using an unintended authentication card. Fixed in version 1.35.0.
MsQuic prior to versions 2.4.20, 2.5.11, and 2.6.1 contains a vulnerability where clients using the OpenSSL or QuicTLS TLS backend do not properly verify that a server certificate matches the intended target server hostname. An on-path attacker can present a certificate that does not match the intended hostname and spoof the server in a man-in-the-middle attack. The Schannel backend is not affected.
Microsoft UFO prior to version 3.0.9 contains a command injection vulnerability in the press_key tool in ufo/client/mcp/http_servers/mobile_mcp_server.py. The key_code parameter is passed to `adb shell input keyevent`, and the adb client joins arguments into a remote command string, allowing an authenticated Mobile MCP caller to execute additional commands as the Android shell user on an authorized connected device. This requires a valid UFO_MCP_API_KEY, adb on the host, and a reachable authorized device.
In Microsoft UFO before version 3.0.9, the /api/task_result/{task_name} endpoint calls SessionManager.get_result_by_task() in ufo/server/services/session_manager.py, which acquires a non-reentrant lock and then attempts to acquire the same lock again when the task name maps to a session. An authenticated attacker can block the request indefinitely, and in the default single-process configuration, the blocked event-loop thread prevents other HTTP, WebSocket, and dependent background interactions.
The run_shell tool in the CommandLineExecutor component of Microsoft UFO before 3.0.9 validates only the first token of the bash_command parameter and permits explorer.exe. On Windows, explorer.exe delegates its following path argument to ShellExecute, allowing an attacker-influenced agent call to launch an arbitrary executable or script as the desktop user even though the subprocess uses shell=False.
HortusFox before 6.2 contains a remote code execution vulnerability in ThemeModule::startImport() where an uploaded ZIP archive is extracted directly into the public web root before any validation of file names, extensions, or content is performed. An authenticated administrator can upload a crafted theme archive containing a PHP file and an .htaccess file to re-enable execution, then request it under the themes directory to execute arbitrary OS commands as the web-server user.
A vulnerability in ESET PROTECT On-Prem involves allocation of resources without limits or throttling, leading to increased CPU and RAM consumption and potentially enabling a Denial-of-Service attack.
Progress Software Autonomous REST Connector GenAI Agents ARCGenAI-Generator version 2.0 contains an OS command injection vulnerability in the shell-based temporary-file cleanup instructions. An attacker who supplies a crafted Swagger/OpenAPI document can execute arbitrary commands on a developer's machine when a user invokes the generator.
In Django 6.1 before 6.1.2, 6.0 before 6.0.9, and 5.2 before 5.2.18, the function django.forms.models.BaseModelFormSet.save_existing_objects() used the presence of a primary key on a submitted form's instance as evidence that the instance belonged to the formset's limiting queryset. An object outside that queryset can be deleted by an authenticated user without permission on the targeted object, via forged management-form data. Models using the default AutoField primary key are not affected.
In Django 6.1 before 6.1.2, 6.0 before 6.0.9, and 5.2 before 5.2.18, an incomplete fix for CVE-2026-15307 in Django spatial lookups allows an attacker who can supply bytes values to cause the Django process to make network requests via a crafted VRT document referencing an external raster source.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

