CVE Vulnerability Catalog

Translated CVE descriptions from NVD NIST - in English

Browse vulnerabilities by package

CISA KEV catalog updated: (v2026.10.30)

Weekly CVE digest

One email a week with newly published vulnerabilities worth knowing about. No account needed.

This digest covers new vulnerabilities in general, not your servers. If you want to know which of them actually run in your infrastructure, that is what Secvalis does: it scans your machines and reports only what concerns them.

I agree to receive the weekly CVE digest at the address above. I can withdraw this consent at any time using the link in the footer of every message.

CVE-2026-47893
High

A Spring WebFlux application that supports WebSocket connections may expose indirectly sensitive user information by including request headers in an exception reason. Affected versions: Spring Framework 7.0.0-7.0.8, 6.2.0-6.2.19, 6.1.0-6.1.28, 6.0.0-6.0.30, 5.3.0-5.3.49, and 5.2.25.RELEASE and earlier.

CVE-2026-47889
High

A WebFlux application running on the Jetty 12 Core reactive adapter serializes response cookies without the sameSite attribute. Affected versions: Spring Framework 7.0.0-7.0.8 and 6.2.0-6.2.19.

CVE-2026-47888
High

A Spring RSocket application is exposed to a memory leak via a malformed SETUP frame. Affected versions: Spring Framework 7.0.0-7.0.8, 6.2.0-6.2.19, 6.1.0-6.1.28, 6.0.0-6.0.30, 5.3.0-5.3.49, and 5.2.0.RELEASE-5.2.25.RELEASE.

CVE-2026-47886
High

Applications that evaluate user-supplied Spring Expression Language (SpEL) expressions may be vulnerable to a Denial of Service (DoS) attack when the power operator (^) is used with a BigDecimal or BigInteger operand and a large exponent value. This affects a wide range of Spring Framework versions.

CVE-2026-47885
High

The PartEventHttpMessageReader in Spring WebFlux does not enforce the maxPartSize limit when maxInMemorySize is set to -1. This affects Spring Framework versions 7.0.0-7.0.8, 6.2.0-6.2.19, and 6.1.0-6.1.28.

CVE-2026-47879
High

Spring Cloud Gateway versions 5.0.0-5.0.2, 4.3.0-4.3.5, 4.0.0-4.2.9, and 3.1.13 and earlier are vulnerable in JsonToGrpcGatewayFilterFactory, allowing arbitrary Spring Resource locations for defining the proto descriptor.

CVE-2026-47877
High

Spring Security Authorization Server versions 7.1.0 and 7.0.0-7.0.6 are vulnerable because the default consent page renders user-controlled values without HTML entity encoding.

CVE-2026-47849
High

Spring Data REST versions 5.1.0, 5.0.0-5.0.6, 4.5.0-4.5.12, 4.0.0-4.4.15, and 3.7.20 and earlier do not guard identifier (@Id) and version (@Version) properties against mutation via RFC 6902 JSON Patch requests.

CVE-2026-19715
High

The WP OAuth Server (Login with WordPress) WordPress plugin before 6.3.1 does not restrict access to the debug log it writes, which is stored at a fixed and publicly reachable location, allowing unauthenticated users to read the OAuth tokens and authorisation codes it has issued as well as user records including password hashes when debug logging is enabled.

CVE-2026-19223
High

The Smush WordPress plugin before 4.3.2 does not restrict a network-wide setting to network administrators, allowing an administrator of any single site on a multisite network to execute arbitrary code across the entire network.

CVE-2026-13415
High

The CMP WordPress plugin before version 4.1.18 does not enforce an option-name allow-list when importing settings via one of its AJAX actions, allowing users with the Editor role (when the administrator has granted the Editor role access to the CMP plugin's admin-bar controls) to update arbitrary WordPress options, including options that lead to privilege escalation to Administrator.

CVE-2026-81491
High

A path traversal vulnerability was found in boxpositron with-context-mcp up to 3.0.7, affecting functions ingest_notes, teleport_notes, sync_notes, and project_folder in src/index.ts. The attack can be launched remotely. The exploit has been published and may be used. The project was informed but has not responded.

CVE-2026-81421
High

A server-side request forgery (SSRF) vulnerability was discovered in ddfourtwo sentry-selfhosted-mcp 0.4.0, in the raw_sentry_api component. Manipulating the endpoint argument allows remote attacks. The exploit has been released publicly. The project was informed but has not responded.

CVE-2026-80183
High

In OpenStack Keystone before 29.0.3, any authenticated user with role:reader on any project can list every project-scoped role assignment under any domain by passing a domain ID as scope.project.id with include_subtree to the GET /v3/role_assignments endpoint. The domain's project record has domain_id=null, causing the policy domain_id check to pass for any caller. With include_names, the response discloses names and home-domain IDs of all users, groups, projects, and roles. An attacker can harvest domain IDs and repeat the query to map role assignments across the entire cloud.

CVE-2026-47852
High

A local attacker on a multi-user host can pre-create the deterministic cache path and plant a malicious ONNX model file. Affects Spring AI versions 2.0.0, 1.1.0-1.1.8, and 1.0.0-1.0.9.

CVE-2026-47851
High

Analyzing a PDF with a deeply nested or cyclic table of contents can cause a StackOverflowError in the ingestion thread. Affects Spring AI versions 2.0.0, 1.1.0-1.1.8, and 1.0.0-1.0.9.

CVE-2026-81203
High

A vulnerability has been found in SourceCodester Simple Online Food Ordering System 1.0. This affects an unknown function of the file /admin/ajax.php?action=login2. The manipulation of the argument email leads to sql injection. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used.

CVE-2026-47666
High

Penpot is an open-source design and prototyping platform. In versions up to and including 2.14.3, Penpot is vulnerable to stored cross-site scripting through custom font family names, which are interpolated into a @font-face CSS rule and injected into the page as HTML without sanitization. Because the backend accepts an arbitrary font-family string and the frontend writes the resulting style through innerHTML, a name containing markup such as a closing style tag followed by a script can break out of the style element and execute JavaScript on the Penpot origin. The attack is passive: any team member who opens a file referencing the malicious font triggers script execution simply by rendering the page, allowing theft of session cookies, actions performed as the victim, and access to their files and projects. This issue is fixed in version 2.15.3.

CVE-2026-47665
High

Penpot is an open-source design and prototyping platform. In versions up to and including 2.14.3, Penpot is vulnerable to stored cross-site scripting through file comments, whose content is stored as raw text and rendered into the page with innerHTML without any sanitization. Because the backend applies only a length check and the frontend writes comment content directly through innerHTML, any team member who can comment on a shared file can embed HTML such as an image error handler or script that executes in the browser of every other collaborator. The attack is passive: any user who opens the comments panel on the affected file triggers script execution on the Penpot origin, allowing theft of session cookies, actions performed as the victim, and access to their files and projects. This issue is fixed in version 2.15.3.

CVE-2026-81202
High

A flaw has been found in itsourcecode Payroll System 1.0. The impacted element is the function create/read/update/delete of the file ajax.php of the component CRUD Operation Handler. Executing a manipulation of the argument action can lead to missing authentication. The attack may be performed from remote. The exploit has been published and may be used.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS