CVE Vulnerability Catalog

Translated CVE descriptions from NVD NIST - in English

Browse vulnerabilities by package

CISA KEV catalog updated: (v2026.11.04)

Weekly CVE digest

One email a week with newly published vulnerabilities worth knowing about. No account needed.

This digest covers new vulnerabilities in general, not your servers. If you want to know which of them actually run in your infrastructure, that is what Secvalis does: it scans your machines and reports only what concerns them.

I agree to receive the weekly CVE digest at the address above. I can withdraw this consent at any time using the link in the footer of every message.

CVE-2026-3886
High
—

A vulnerability in the virtio-gpu module of the Linux kernel involves an incorrect overflow check when allocating 2D images. This flaw can lead to a buffer overflow, potentially enabling privilege escalation or system crash.

CVE-2025-52565
High
—

runc is a CLI tool for spawning and running containers according to the OCI specification. Versions 1.0.0-rc3 through 1.2.7, 1.3.0-rc.1 through 1.3.2, and 1.4.0-rc.1 through 1.4.0-rc.2, due to insufficient checks when bind-mounting `/dev/pts/$n` to `/dev/console` inside the container, an attacker can...

CVE-2025-48385
High
—

Git is a fast, scalable, distributed revision control system. When cloning a repository Git knows to optionally fetch a bundle advertised by the remote server, which allows the server-side to offload.

CVE-2024-6197
High
—

libcurl's ASN1 parser has this utf8asn1str() function used for parsing an ASN.1 UTF-8 string. It can detect an invalid field and return error. Unfortunately, when doing so it also invokes `free()` on a 4 byte local stack buffer. Most modern malloc implementations detect this error and immediately abort.

GHSA-f88m-g3jw-g9cj
High
—

Several vulnerabilities have been discovered and fixed in the upstream libvips dependency, two rated as high severity using CVSSv4. Versions of sharp prior to 0.35.0 processing untrusted input are affected.

GHSA-hrxh-6v49-42gf
High
—

Multiple security vulnerabilities have been identified in the grpc-go library affecting the xDS RBAC authorization engine and the HTTP/2 transport server implementation. These vulnerabilities could lead to authorization bypass (Fail-Open) during rule translation.

CVE-2024-12797
High
—

Clients using RFC7250 Raw Public Keys (RPKs) to authenticate a server may fail to notice that the server was not authenticated, because handshakes don't abort as expected when the SSL_VERIFY_PEER verification mode is set. Impact: TLS and DTLS connections using raw public keys...

CVE-2025-26519
High
—

musl libc 0.9.13 through 1.2.5 before 1.2.6 has an out-of-bounds write vulnerability when an attacker can trigger iconv conversion of untrusted EUC-KR text to UTF-8.

GHSA-w8jc-g24h-crhw
High
—

GitPython spent 2022-2026 rolling out two reusable guards method-by-method: Git.check_unsafe_protocols(url) (raises UnsafeProtocolError for <transport>:: remote-helper URLs) and Git.check_unsafe_options(...) (raises UnsafeOptionError for denylisted options). The description indicates the rollout did not cover all code paths.

CVE-2026-112902
High
—

In Pillow's libtiff encoder (PyImaging_LibTiffEncoderNew in src/encode.c), crafted TIFF tags can cause memory disclosure and a segfault. The issue occurs when creating the LibTiff encoder.

GHSA-23mf-xhv8-69c2
High
—

The description of this report does not contain sufficient technical information about the vulnerability — it only includes a note about the reporting method and references to files that were not attached. The nature and scope of the issue cannot be determined from it.

GHSA-2g87-pp6c-29x5
High
—

Multiple cases were found in aiohttp where excessive or unbounded memory use, or excessive CPU consumption, can be triggered by attacker-controlled requests. An attacker could cause resource exhaustion through specially crafted requests.

GHSA-jm78-9fvv-mhgr
High
—

GitPython's config-name validator only neutralizes CR/LF/NUL for the "option" label; it does not reject =, #, ;, [, ], or whitespace in an option name. write_section writes the option name verbatim into the config file, so an option name such as sshCommand = touch <cmd> can inject configuration.

GHSA-78g4-xqwv-q3g8
High
—

Pillow wheels from 11.1.0 onward bundle a libopenjp2 containing a heap-buffer-overflow write that is fixed upstream on master but has never appeared in an OpenJPEG release. Because the wheel bundles its own copy, a patched host library does not protect against the issue.

CVE-2026-49272
High
—

A call to the token endpoint with a grant type of urn:ietf:params:oauth:grant-type:device_code and a bogus device_code can obtain a bearer token as long as a valid client ID enabled for the device workflow is known. This violates RFC 8628.

CVE-2026-44291
High
—

W wersjach przed 7.5.6 i 8.0.2, protobufjs używał zwykłych obiektów z dziedziczonymi prototypami do wewnętrznych tabel wyszukiwania typów. Jeśli Object.prototype został wcześniej zanieczyszczony, te tabele wyszukiwania mogły być narażone na ataki.

CVE-2026-33671
High
—

Picomatch to matcher glob napisany w JavaScript. Wersje przed 4.0.4, 3.0.2 i 2.3.2 są podatne na atak typu Regular Expression Denial of Service (ReDoS) podczas przetwarzania stworzonych wzorców extglob.

CVE-2022-25883
High
—

Wersje pakietu semver przed 7.5.2 są podatne na atak Denial of Service (DoS) za pomocą wyrażeń regularnych (ReDoS) poprzez funkcję new Range, gdy nieufne dane użytkownika są dostarczane jako zakres.

GHSA-5c6j-r48x-rmvq
High
—

Pakiet npm serialize-javascript (wersje <= 7.0.2) zawiera podatność na wstrzykiwanie kodu. Jest to niekompletne rozwiązanie dla CVE-2020-7660.

CVE-2026-27601
High
—

Underscore.js to biblioteka narzędziowa dla JavaScript. W wersjach przed 1.13.8 funkcje _.flatten i _.isEqual wykorzystują rekurencję bez limitu głębokości, co w określonych warunkach może prowadzić do ataku typu Denial of Service (DoS) poprzez wywołanie przepełnienia stosu.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS