CVE Vulnerability Catalog

Translated CVE descriptions from NVD NIST - in English

Browse vulnerabilities by package

CISA KEV catalog updated: (v2026.11.03)

Weekly CVE digest

One email a week with newly published vulnerabilities worth knowing about. No account needed.

This digest covers new vulnerabilities in general, not your servers. If you want to know which of them actually run in your infrastructure, that is what Secvalis does: it scans your machines and reports only what concerns them.

I agree to receive the weekly CVE digest at the address above. I can withdraw this consent at any time using the link in the footer of every message.

GHSA-j95f-988m-3j2f
High
—

@tiptap/core contains two quadratic regular-expression denial-of-service paths in its default Markdown attribute parsers. Pandoc-style block attributes use two unanchored greedy expressions that rescan repeated __QUOTED_0 prefixes. Inline shortcode attributes use another unanchored expression, which can lead to resource exhaustion.

CVE-2025-26519
High
—

musl libc 0.9.13 through 1.2.5 before 1.2.6 has an out-of-bounds write vulnerability when an attacker can trigger iconv conversion of untrusted EUC-KR text to UTF-8.

CVE-2025-52565
High
—

runc is a CLI tool for spawning and running containers according to the OCI specification. Versions 1.0.0-rc3 through 1.2.7, 1.3.0-rc.1 through 1.3.2, and 1.4.0-rc.1 through 1.4.0-rc.2, due to insufficient checks when bind-mounting `/dev/pts/$n` to `/dev/console` inside the container, an attacker can...

CVE-2025-48385
High
—

Git is a fast, scalable, distributed revision control system. When cloning a repository Git knows to optionally fetch a bundle advertised by the remote server, which allows the server-side to offload.

CVE-2024-6197
High
—

libcurl's ASN1 parser has this utf8asn1str() function used for parsing an ASN.1 UTF-8 string. It can detect an invalid field and return error. Unfortunately, when doing so it also invokes `free()` on a 4 byte local stack buffer. Most modern malloc implementations detect this error and immediately abort.

CVE-2024-45338
High
—

An attacker can craft an input to the Parse functions that would be processed non-linearly with respect to its length, resulting in extremely slow parsing. This could cause a denial of service.

GHSA-6wmv-xq9m-fmp7
High
—

Dalli's meta protocol request formatter writes some numeric arguments into memcached commands without converting them to integers. If an application passes an attacker-controlled String to one of these arguments, CRLF sequences in it are sent to memcached as additional commands on the same connection.

CVE-2026-3886
High
—

A vulnerability in the virtio-gpu module of the Linux kernel involves an incorrect overflow check when allocating 2D images. This flaw can lead to a buffer overflow, potentially enabling privilege escalation or system crash.

GHSA-hrxh-6v49-42gf
High
—

Multiple security vulnerabilities have been identified in the grpc-go library affecting the xDS RBAC authorization engine and the HTTP/2 transport server implementation. These vulnerabilities could lead to authorization bypass (Fail-Open) during rule translation.

CVE-2024-56406
High
—

A heap buffer overflow vulnerability was discovered in Perl. Affected versions include release branches 5.34, 5.36, 5.38, and 5.40, as well as development versions from 5.33.1 through 5.41.10. When non-ASCII bytes are present in the left-hand side of the `tr` operator, `S_do_trans_invmap` can overflow the buffer.

CVE-2023-47038
High
—

A vulnerability in Perl 5.30.0 through 5.38.0 allows a heap buffer overflow when compiling a crafted regular expression. An attacker can exploit this to cause a controlled buffer overflow.

CVE-2019-16226
High
—

An issue was discovered in py-lmdb 0.97 where mdb_node_del does not validate a memmove in the case of an unexpected node->mn_hi, leading to an invalid write operation. This occurs when accessing a data.mdb file supplied by an attacker.

GHSA-f9j4-qggq-h239
High
—

In GitPython, Remote.pull() forwards its positional refspec argument directly to the git pull child process while its unsafe-option guard inspects only keyword arguments. An application that passes attacker-influenced data as the refspec (e.g., a user-supplied branch name) may allow injection of unsafe options.

GHSA-537c-gmf6-5ccf
High
—

The wheels of pyca/cryptography include a statically linked copy of OpenSSL. The versions of OpenSSL included in wheels prior to cryptograph 48.01 are vulnerable to a security issue.

CVE-2026-31802
High
—

node-tar to pełnoprawne narzędzie Tar dla Node.js. Przed wersją 7.5.11, tar (npm) może być oszukany w celu utworzenia symlinków wskazujących poza katalog ekstrakcji, co umożliwia nadpisywanie plików poza bieżącym katalogiem roboczym.

GHSA-pp92-crg2-gfv9
High
—

The vulnerability occurs when an application uses OAuth2::Client and the authorization server returns a redirect with a Location header in the form of a protocol-relative URI. In this case, OAuth2::Client#request may incorrectly resolve the redirect.

GHSA-p8jg-8p9f-pgmr
High
—

The faraday-http-cache library stores cached responses in JSON format by default and reads them back using JSON.load, which honors the json_class key and calls json_create on the named class. Response headers are stored verbatim in the cache entry, so a malicious origin server can return a response with a json_class key leading to unsafe deserialization.

CVE-2026-33663
High
—

n8n to platforma automatyzacji przepływu pracy typu open source. Przed wersjami 2.14.1, 2.13.3 i 1.123.27, uwierzytelniony użytkownik z rolą `global:member` mógł wykorzystać łańcuchowe błędy autoryzacji w potoku poświadczeń n8n, aby ukraść tajne dane w postaci niezaszyfrowanej z ogólnych poświadczeń HTTP.

CVE-2026-25055
High
—

n8n to platforma automatyzacji procesów roboczych typu open source. Przed wersjami 1.123.12 i 2.4.0, podczas przetwarzania przesłanych plików i ich transferu do zdalnych serwerów za pomocą węzła SSH, brak walidacji metadanych może prowadzić do zapisywania plików w niezamierzonych lokalizacjach.

CVE-2026-27494
High
—

n8n to platforma automatyzacji procesów roboczych typu open source. Przed wersjami 2.10.1, 2.9.3 i 1.123.22, uwierzytelniony użytkownik z uprawnieniami do tworzenia lub modyfikowania procesów roboczych mógł wykorzystać węzeł Python Code do ucieczki z piaskownicy.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS