CVE Vulnerability Catalog

Translated CVE descriptions from NVD NIST - in English

Browse vulnerabilities by package

CISA KEV catalog updated: (v2026.10.30)

Weekly CVE digest

One email a week with newly published vulnerabilities worth knowing about. No account needed.

This digest covers new vulnerabilities in general, not your servers. If you want to know which of them actually run in your infrastructure, that is what Secvalis does: it scans your machines and reports only what concerns them.

I agree to receive the weekly CVE digest at the address above. I can withdraw this consent at any time using the link in the footer of every message.

CVE-2026-32887
High
—

Effect to framework TypeScript składający się z kilku pakietów, które współpracują w celu budowy aplikacji TypeScript. Przed wersją 3.20.0, używając `RpcServer.toWebHandler` (lub `HttpApp.toWebHandlerRuntime`) w handlerze trasy Next.js App Router, występowały problemy z `AsyncLocalStorage` w Node.js.

CVE-2026-23268
High
—

W jądrze Linuxa zidentyfikowano podatność, która pozwala nieuprzywilejowanemu lokalnemu użytkownikowi na zarządzanie politykami AppArmor. Użytkownik może załadować, zastąpić lub usunąć profile, wykorzystując atak 'confused deputy', co prowadzi do pełnego zarządzania polityką.

CVE-2026-29087
High
—

W wersjach przed 1.19.10 biblioteki @hono/node-server, podczas korzystania z serwowania statycznych plików oraz ochrony opartych na trasach, występuje niespójne dekodowanie URL, co może umożliwić dostęp do chronionych zasobów statycznych.

GHSA-m64x-33q8-m5h7
High
—

This is a residual of GHSA-g5vv-9gxw-82hx / CVE-2026-87819. The 3.1.60 fix made Actor._from_string regex-free, but parse_actor_and_date still runs _re_actor_epoch on the same author/committer/tagger line one step earlier. That pattern backtracks quadratically when the trailing epo...

CVE-2026-46483
High
—

Vim to otwartoźródłowy edytor tekstu działający w wierszu poleceń. Przed wersją 9.2.0479 występuje podatność na wstrzykiwanie poleceń w funkcji tar#Vimuntar() w pliku runtime/autoload/tar.vim podczas dekompresji archiwów .tgz w systemach podobnych do Unix.

CVE-2026-112902
High
—

In Pillow's libtiff encoder (PyImaging_LibTiffEncoderNew in src/encode.c), crafted TIFF tags can cause memory disclosure and a segfault. The issue occurs when creating the LibTiff encoder.

CVE-2026-33747
High
—

BuildKit to narzędzie do konwertowania kodu źródłowego na artefakty budowlane. Przed wersją 0.28.1, korzystając z niestandardowego frontendu BuildKit, frontend mógł stworzyć wiadomość API, która powodowała zapis plików poza katalogiem stanu BuildKit.

CVE-2026-26960
High
—

node-tar to pełnofunkcjonalny program Tar dla Node.js. W wersjach 7.5.7 i poniżej, przy użyciu domyślnych opcji, złośliwy archiwum może utworzyć twardy link w katalogu ekstrakcji, który wskazuje na plik poza katalogiem głównym ekstrakcji, co umożliwia odczyt i zapis dowolnych plików jako użytkownik wykonujący ekstrakcję.

CVE-2026-33713
High
—

n8n to otwartoźródłowa platforma do automatyzacji procesów. Przed wersjami 2.14.1, 2.13.3 i 1.123.26, uwierzytelniony użytkownik z uprawnieniami do tworzenia lub modyfikowania procesów mógł wykorzystać podatność na wstrzyknięcie SQL w węźle 'Data Table Get'.

CVE-2023-45283
High
—

The filepath package in Go does not recognize paths with a \??\ prefix as special. On Windows, a path starting with \??\ is equivalent to a path starting with \\?\ and can be used to access arbitrary system locations.

CVE-2023-39325
High
—

A vulnerability in Go's HTTP/2 implementation allows a malicious client to rapidly create and reset requests, causing excessive server resource consumption. Although the number of concurrent streams is limited by MaxConcurrentStreams, resetting requests enables the attacker to continuously send new requests.

GHSA-p6gq-j5cr-w38f
High
—

In nodemailer v9.0.0, the message-level `raw` option bypasses `disableFileAccess` and `disableUrlAccess` protections, enabling arbitrary file reads and full SSRF (Server-Side Request Forgery) in the sent message.

CVE-2025-27152
High
—

A vulnerability in the axios library allows sending requests to absolute URLs instead of relative ones, potentially leading to SSRF attacks and credential leakage. Even with baseURL set, axios ignores it and sends the request to the specified absolute URL.

CVE-2020-36604
High
—

A vulnerability in the hoek library before version 8.5.1 and 9.x before 9.0.3 allows prototype poisoning in the clone function. An attacker can exploit this flaw to modify object prototypes, leading to unauthorized access or code execution.

CVE-2023-50387
High
—

The KeyTrap vulnerability in the DNSSEC protocol allows a remote attacker to cause a Denial of Service (DoS) by sending DNSSEC responses containing many DNSKEY and RRSIG records. This leads to excessive CPU consumption on the DNS server, potentially causing overload.

CVE-2023-31484
High
—

CPAN.pm before version 2.35 does not verify TLS certificates when downloading distributions over HTTPS. This allows man-in-the-middle attackers to replace downloaded packages with malicious ones.

CVE-2019-20916
High
—

The pip package before version 19.2 for Python is vulnerable to directory traversal when a URL is provided in an install command. An attacker can exploit a Content-Disposition header containing '../' in the filename to overwrite files, such as /root/.ssh/authorized_keys.

CVE-2023-50868
High
—

A vulnerability in the DNS protocol, related to the Closest Encloser Proof aspect in RFC 5155 (when RFC 9276 guidance is skipped), allows remote attackers to cause a denial of service (DoS) by triggering excessive CPU consumption for SHA-1 computations. The attack involves sending DNSSEC responses in a random subdomain attack, known as the NSEC3 issue.

CVE-2019-3844
High
—

It was discovered that a systemd service using the DynamicUser property can gain new privileges through the execution of SUID binaries, allowing creation of binaries owned by the service's transient group with the setgid bit set. A local attacker may exploit this flaw to access resources that will be.

CVE-2022-42919
High
—

A vulnerability in Python 3.9.x before 3.9.16 and 3.10.x before 3.10.9 on Linux allows local privilege escalation in a non-default configuration. The multiprocessing library with the forkserver start method permits pickle deserialization from any user on the same local network of the machine.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS