CVE Vulnerability Catalog

Translated CVE descriptions from NVD NIST - in English

Browse vulnerabilities by package

CISA KEV catalog updated: (v2026.10.28)

Weekly CVE digest

One email a week with newly published vulnerabilities worth knowing about. No account needed.

This digest covers new vulnerabilities in general, not your servers. If you want to know which of them actually run in your infrastructure, that is what Secvalis does: it scans your machines and reports only what concerns them.

I agree to receive the weekly CVE digest at the address above. I can withdraw this consent at any time using the link in the footer of every message.

GHSA-wq5f-xc86-pv6w
High
—

A memory-related vulnerability has been discovered and fixed in the librsvg dependency. Under certain runtime-specific conditions, it can lead to possible remote code execution (RCE) on glibc-based Linux.

CVE-2026-33663
High
—

n8n to platforma automatyzacji przepływu pracy typu open source. Przed wersjami 2.14.1, 2.13.3 i 1.123.27, uwierzytelniony użytkownik z rolą `global:member` mógł wykorzystać łańcuchowe błędy autoryzacji w potoku poświadczeń n8n, aby ukraść tajne dane w postaci niezaszyfrowanej z ogólnych poświadczeń HTTP.

CVE-2026-46483
High
—

Vim to otwartoźródłowy edytor tekstu działający w wierszu poleceń. Przed wersją 9.2.0479 występuje podatność na wstrzykiwanie poleceń w funkcji tar#Vimuntar() w pliku runtime/autoload/tar.vim podczas dekompresji archiwów .tgz w systemach podobnych do Unix.

CVE-2026-33713
High
—

n8n to otwartoźródłowa platforma do automatyzacji procesów. Przed wersjami 2.14.1, 2.13.3 i 1.123.26, uwierzytelniony użytkownik z uprawnieniami do tworzenia lub modyfikowania procesów mógł wykorzystać podatność na wstrzyknięcie SQL w węźle 'Data Table Get'.

CVE-2026-27904
High
—

minimatch to minimalne narzędzie do dopasowywania, które konwertuje wyrażenia glob na obiekty RegExp w JavaScript. W wersjach przed 10.2.3, 9.0.7, 8.0.6, 7.4.8, 6.2.2, 5.1.8, 4.2.5 i 3.1.4 zagnieżdżone `*()` extgloby generują wyrażenia regularne z zagnieżdżonymi nieograniczonymi kwantyfikatorami, co prowadzi do katastrofalnych skutków.

CVE-2026-42236
High
—

n8n to platforma automatyzacji procesów roboczych typu open source. Przed wersjami 1.123.32, 2.17.4 i 2.18.1, punkt rejestracji klienta OAuth MCP akceptował nieautoryzowane żądania i przechowywał dane klientów bez odpowiednich kontroli zasobów.

CVE-2026-25547
High
—

@isaacs/brace-expansion to hybrydowy fork TypeScript brace-expansion, który przed wersją 5.0.1 jest podatny na atak typu denial of service (DoS) spowodowany nieograniczonym rozszerzaniem zakresów klamrowych. Atakujący może dostarczyć wzór zawierający powtarzające się numeryczne zakresy klamrowe.

CVE-2026-33722
High
—

n8n to platforma automatyzacji procesów roboczych typu open source. Przed wersjami 2.6.4 i 1.123.23, uwierzytelniony użytkownik bez uprawnień do wyświetlania zewnętrznych sekretów mógł odwołać się do sekretu za pomocą zewnętrznej nazwy w poświadczeniu i uzyskać jego wartość w postaci tekstu jawnego podczas zapisywania poświadczenia.

GHSA-f9j4-qggq-h239
High
—

In GitPython, Remote.pull() forwards its positional refspec argument directly to the git pull child process while its unsafe-option guard inspects only keyword arguments. An application that passes attacker-influenced data as the refspec (e.g., a user-supplied branch name) may allow injection of unsafe options.

CVE-2026-32887
High
—

Effect to framework TypeScript składający się z kilku pakietów, które współpracują w celu budowy aplikacji TypeScript. Przed wersją 3.20.0, używając `RpcServer.toWebHandler` (lub `HttpApp.toWebHandlerRuntime`) w handlerze trasy Next.js App Router, występowały problemy z `AsyncLocalStorage` w Node.js.

CVE-2026-29087
High
—

W wersjach przed 1.19.10 biblioteki @hono/node-server, podczas korzystania z serwowania statycznych plików oraz ochrony opartych na trasach, występuje niespójne dekodowanie URL, co może umożliwić dostęp do chronionych zasobów statycznych.

GHSA-537c-gmf6-5ccf
High
—

The wheels of pyca/cryptography include a statically linked copy of OpenSSL. The versions of OpenSSL included in wheels prior to cryptograph 48.01 are vulnerable to a security issue.

CVE-2023-50868
High
—

A vulnerability in the DNS protocol, related to the Closest Encloser Proof aspect in RFC 5155 (when RFC 9276 guidance is skipped), allows remote attackers to cause a denial of service (DoS) by triggering excessive CPU consumption for SHA-1 computations. The attack involves sending DNSSEC responses in a random subdomain attack, known as the NSEC3 issue.

CVE-2025-26519
High
—

musl libc 0.9.13 through 1.2.5 before 1.2.6 has an out-of-bounds write vulnerability when an attacker can trigger iconv conversion of untrusted EUC-KR text to UTF-8.

CVE-2025-52565
High
—

runc is a CLI tool for spawning and running containers according to the OCI specification. Versions 1.0.0-rc3 through 1.2.7, 1.3.0-rc.1 through 1.3.2, and 1.4.0-rc.1 through 1.4.0-rc.2, due to insufficient checks when bind-mounting `/dev/pts/$n` to `/dev/console` inside the container, an attacker can...

CVE-2025-48385
High
—

Git is a fast, scalable, distributed revision control system. When cloning a repository Git knows to optionally fetch a bundle advertised by the remote server, which allows the server-side to offload.

CVE-2024-6197
High
—

libcurl's ASN1 parser has this utf8asn1str() function used for parsing an ASN.1 UTF-8 string. It can detect an invalid field and return error. Unfortunately, when doing so it also invokes `free()` on a 4 byte local stack buffer. Most modern malloc implementations detect this error and immediately abort.

CVE-2023-47038
High
—

A vulnerability in Perl 5.30.0 through 5.38.0 allows a heap buffer overflow when compiling a crafted regular expression. An attacker can exploit this to cause a controlled buffer overflow.

CVE-2024-12797
High
—

Clients using RFC7250 Raw Public Keys (RPKs) to authenticate a server may fail to notice that the server was not authenticated, because handshakes don't abort as expected when the SSL_VERIFY_PEER verification mode is set. Impact: TLS and DTLS connections using raw public keys...

CVE-2026-3886
High
—

A vulnerability in the virtio-gpu module of the Linux kernel involves an incorrect overflow check when allocating 2D images. This flaw can lead to a buffer overflow, potentially enabling privilege escalation or system crash.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS