CVE Vulnerability Catalog

Translated CVE descriptions from NVD NIST - in English

Browse vulnerabilities by package

CISA KEV catalog updated: (v2026.11.04)

Weekly CVE digest

One email a week with newly published vulnerabilities worth knowing about. No account needed.

This digest covers new vulnerabilities in general, not your servers. If you want to know which of them actually run in your infrastructure, that is what Secvalis does: it scans your machines and reports only what concerns them.

I agree to receive the weekly CVE digest at the address above. I can withdraw this consent at any time using the link in the footer of every message.

CVE-2026-93597
High

ArcadeDB versions before 26.9.1 fail to validate IPv6 transition addresses in the SSRF guard used by IMPORT DATABASE and server commands. Authenticated attackers can supply URLs resolving to NAT64, 6to4, or Teredo addresses embedding RFC 1918 or loopback IPv4 payloads to reach internal services and cloud metadata endpoints.

CVE-2026-93596
Medium

A vulnerability in ArcadeDB before 26.9.1 allows an authenticated low-privilege user to bypass ACL enforcement on vertex and edge types. This is triggered by sending a batch request to POST /api/v1/batch/{database} with default parallel processing, which fails to bind the user principal to the async worker threads. The user can then append edges to protected vertices, modifying graph data without authorization.

CVE-2026-93595
Medium

A vulnerability in ArcadeDB before 26.9.1 exists in the query_database tool exposed through AI chat endpoints. The tool executes queries without binding the authenticated user to the database context, causing per-type and per-bucket ACL checks to fail. Authenticated users can read data they are explicitly denied at the type level.

CVE-2026-93594
High

ArcadeDB (com.arcadedb:arcadedb-engine) through 26.8.1 enforces per-type/per-record access-control rules only in LocalBucket, keyed on file id. Query paths reaching data through LSM index files or the TimeSeries engine never invoke that check, so an authenticated user denied readRecord/deleteRecord can still read indexed key values, record IDs, MAX/MIN values, TimeSeries samples, learn record counts, and delete index entries, desynchronizing the index from data. Index and type names are discoverable via SELECT FROM schema:indexes. Affects embedded and server deployments and all transports. Fixed in 26.9.1.

CVE-2026-93593
High

ArcadeDB before 26.9.1 fails to enforce security-group types ACL entries for TimeSeries types because the ACL resolver builds permissions from bucket IDs, but TimeSeries types do not own normal record buckets. An authenticated low-privilege user can read or insert TimeSeries samples despite explicit deny rules by exploiting the missing type-name-based access check that causes permission lookups to fail open.

CVE-2026-93592
High

vLLM versions before 0.28.0 fail to validate the lower bound of token IDs in the /v1/embeddings and /pooling endpoints, allowing unauthenticated attackers to crash the engine by submitting negative token IDs. A single request with a negative token ID triggers a CUDA device-side assertion that poisons the GPU context, causing all subsequent requests to fail until the process restarts.

CVE-2026-93591
High

SiYuan versions before 3.8.3 contain an SQL injection vulnerability in the graph.go query2Stmt function where tag values are concatenated raw into SQL string literals without escaping single quotes. A publish-mode reader or anonymous visitor can inject SQL via inline HTML span tags in the getGraph endpoint to execute arbitrary queries on the read-write database and exfiltrate private data across notebooks.

CVE-2026-93590
Low

ImageMagick before 7.1.2-31 contains a policy bypass vulnerability in the UHDR encoder that fails to perform policy checks during buffer allocation for image pixels. Attackers can bypass resource policies by processing specially crafted UHDR images, potentially causing denial of service through excessive memory allocation.

CVE-2026-93589
Low

ImageMagick before 7.1.2-31 and 6.9.13-56 contains a division-by-zero flaw in the FLIF encoder. An incorrect value for ticks per second in the image being encoded causes a divide-by-zero and crashes the encoder, resulting in a denial of service.

CVE-2026-93588
Low

ImageMagick before 7.1.2-31 and before 6.9.13-56 contains a NULL pointer dereference in the PNM coder. When the coder reaches a memory (resource) limit at a specific point during processing, the failed allocation is not handled and a NULL pointer is dereferenced, which can lead to a denial of service (application crash) when processing a specially crafted or sufficiently large PNM image.

CVE-2026-93587
Low

ImageMagick before 7.1.2-31 and before 6.9.13-56 contains a policy bypass in the PCD (and, per the upstream advisory, CUBE and HALD) coder: when a specific command line option is supplied, the decoder does not check a configured resource limit, which can result in extra memory allocation. A local user able to pass command line options to ImageMagick can therefore exceed the intended memory policy limit, causing a limited availability impact.

CVE-2026-93586
Low

ImageMagick before 7.1.2-31 and before 6.9.13-56 contains a use-after-free vulnerability in the ImagesToBlob method, caused by a pointer that is not updated correctly. Exploitation may result in a limited availability impact (e.g., a crash of the affected process).

CVE-2026-93560
High

A flaw in the Netty STOMP codec. A remote attacker can send a specially crafted STOMP frame with a content-length header exceeding the maximum integer value. This integer truncation vulnerability can lead to an infinite decode loop.

CVE-2026-93504
Medium

A vulnerability in SveltyCMS 0.0.6 in the user attribute update endpoint allows improper access controls, letting a remote attacker modify user attributes without authorization. A patch is available as commit 05b4f9efeb79e9d72a693232334d7529687f896f.

CVE-2026-93019
Critical

Imager versions before 1.036 for Perl exit the process when reading a TGA file with a colour map length of 32768 or more in tga_palette_read. The two-byte length is unpacked into a signed short, so 32768 or more becomes negative, then cast to size_t, causing mymalloc() to request a size near SIZE_MAX. The allocation fails and Imager's allocator calls exit(3).

CVE-2026-93018
Medium

Imager versions before 1.036 for Perl disclose uninitialised heap memory when reading a paletted image with pixel indexes past its colour map in i_gpix_p and i_glin_p. The palette is allocated uninitialised, and the TGA reader stores pixel indexes without checking them against the colour map, allowing reads of prior heap contents.

CVE-2026-88623
High

NUUO Network Video Recorder 2.0.0 is vulnerable to arbitrary file read. In up.php, the url parameter submitted via POST is received and fopen() opens the URL in binary read-only mode, then the content is written to /tmp/ with a filename derived from basename() of the URL. This operation requires no authentication.

CVE-2026-88622
HighEPSS 64%

NUUO Network Video Recorder 2.0.0 is vulnerable to Command Injection in handle_import_privilege.php.

CVE-2026-79294
Medium

A Cross-Site Scripting (XSS) vulnerability in Moonshot AI Kimi allows a remote attacker to execute arbitrary code via the HTML artifact preview in the public share view. The version as of 2026-07-18 is affected.

CVE-2026-62282
Medium

A vulnerability in OpenCVE before 3.0.0 allows an authenticated user with permission to configure notification channels to trigger requests to arbitrary hosts, including internal network resources, localhost, link-local addresses, and cloud metadata services. The notification testing for Webhook and Slack does not sufficiently validate destination URLs, potentially leaking information.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS