CVE Vulnerability Catalog
Translated CVE descriptions from NVD NIST - in English
Browse vulnerabilities by packageCISA KEV catalog updated: (v2026.11.04)
Weekly CVE digest
One email a week with newly published vulnerabilities worth knowing about. No account needed.
This digest covers new vulnerabilities in general, not your servers. If you want to know which of them actually run in your infrastructure, that is what Secvalis does: it scans your machines and reports only what concerns them.
Notepad++ is a free and open-source source code editor. Prior to 8.9.8, Notepad++ incompletely enforces shortcuts.xml HMAC validation because WM_MACRODLGRUNMACRO, the Run a Macro Multiple Times entry point, calls macroPlayback() without the validation used by command(). A tampered shortcuts.xml macro that is blocked through the Macro menu or a shortcut key can therefore execute through the multi-run dialog and invoke internal Notepad++ commands, including commands that launch external programs, in the current user context. This issue is fixed in version 8.9.8.
Notepad++ prior to 8.9.8 contains a stack buffer overflow in PluginsManager::loadPluginFromPath because the plugin-supplied GetLexerCount() result controls a loop that writes to containers[30] without enforcing NB_MAX_EXTERNAL_LANG. A malicious or compromised plugin that reports more than 30 lexers can write beyond the stack array and corrupt control data, which can permit arbitrary code execution in the Notepad++ process context.
Adobe Campaign Classic (ACC) is affected by an Improper Control of Generation of Code ('Code Injection') vulnerability that could result in arbitrary code execution in the context of the current user. An attacker could exploit this vulnerability to execute arbitrary code. Exploitation does not require user interaction. Scope is changed.
Adobe Campaign Classic (ACC) is affected by a Server-Side Request Forgery (SSRF) vulnerability that could result in privilege escalation. Exploitation does not require user interaction. Scope is changed.
Netdata Windows Agent from version 2.0.0 until 2.10.4 launches powershell.exe and wevtutil.exe as elevated interactive processes in the initiating user's desktop session during MSI repair. A low-privileged local user who triggers repair can interact with or hijack those visible process windows to execute arbitrary commands with SYSTEM privileges.
Adobe Campaign Classic (ACC) is affected by a Server-Side Request Forgery (SSRF) vulnerability that could result in privilege escalation. A low-privileged attacker could exploit this vulnerability to gain elevated access to internal resources. Exploitation does not require user interaction. Scope is changed.
Adobe Campaign Classic (ACC) is affected by a Server-Side Request Forgery (SSRF) vulnerability that could result in privilege escalation. A low-privileged attacker could exploit this vulnerability to gain elevated access to internal resources. Exploitation does not require user interaction. Scope is changed.
Adobe Campaign Classic is affected by an SQL Injection vulnerability due to improper neutralization of special elements in SQL commands. A low-privileged attacker could bypass security measures and gain unauthorized read and limited write access. Exploitation does not require user interaction.
Adobe Campaign Classic is affected by an SQL Injection vulnerability due to improper neutralization of special elements in SQL commands. A low-privileged attacker could execute arbitrary code in the context of the current user. Exploitation does not require user interaction.
Adobe Campaign Classic is affected by an SQL Injection vulnerability due to improper neutralization of special elements in SQL commands. An attacker with high privileges could execute arbitrary SQL commands in the context of the current user. Exploitation does not require user interaction.
Adobe Campaign Classic is affected by an Improper Input Validation vulnerability that could result in arbitrary code execution in the context of the current user. A low-privileged attacker could exploit this vulnerability to execute arbitrary code. Exploitation does not require user interaction.
Adobe Campaign Classic is affected by an Improper Input Validation vulnerability that could result in arbitrary code execution in the context of the current user. A low-privileged attacker could exploit this vulnerability to execute arbitrary code, though exploitation depends on conditions beyond the attacker's control and does not require user interaction.
RTI Connext Professional (Core Libraries) contains a stack-based buffer overflow vulnerability that allows overflow buffers. This issue affects Connext Professional versions from 7.4.0 before 7.7.0.1, from 7.0.0 before 7.3.1.6, from 6.1.0 before 6.1.*, from 6.0.0 before 6.0.*, from 5.3.0 before 5.3.*, from 5.2.0 before 5.2.*, and from 4.3x before 5.1.*.
Notepad++ prior to 8.9.8 allows the Folder as Workspace Run by system action to resolve a different sibling file than the file selected by the user. When an attacker places a command script whose name is the selected text-file path with .cmd appended, and the user invokes Run by system on the text file on Windows 10 or Windows 11, Notepad++ can execute the sibling script as the current user instead of opening the selected file.
MCP Atlassian prior to 0.22.0 has a backslash authority confusion in validate_url_for_ssrf because it interprets the authority differently from the Requests connection layer in the header-based Jira and Confluence URL authentication flow. A crafted URL can validate as an external hostname while the HTTP client connects to an internal host, permitting server-side requests to protected network resources.
MCP Atlassian prior to 0.22.0 has validate_safe_path defaulting its base directory to os.getcwd(), and affected Confluence attachment call sites omit base_dir, allowing attacker-selected writes within the working directory. This Python module overwrite can provide code execution when the application later imports the modified module, bypassing the remediation tracked as CVE-2026-27825.
MCP Atlassian prior to 0.22.0 treats caller-controlled file_path values as trusted server-local paths. The server opens the selected file and uploads it to an Atlassian issue or page, allowing an MCP caller with upload access to disclose any file readable by the server process. This issue is fixed in version 0.22.0.
MCP Atlassian prior to 0.22.0 processes the X-Atlassian-Jira-Url and X-Atlassian-Confluence-Url headers in _process_authentication_headers and uses them to construct Atlassian fetchers without calling validate_url_for_ssrf. A caller who can set these headers can supply an internal or metadata-service URL and cause the server to send requests to that destination, bypassing the incomplete CVE-2026-27826 remediation.
MCP Atlassian prior to 0.22.0 resolves and validates header-supplied Jira or Confluence URLs before the HTTP client resolves the hostname again for the connection. An unauthenticated caller can use a DNS-rebinding hostname that returns a public address during validation and an internal address during connection, causing requests to internal or metadata services. This issue is fixed in version 0.22.0.
MCP Atlassian prior to 0.22.0 omits _make_ssrf_safe_hook from JiraFetcher and ConfluenceFetcher sessions created through the basic-auth and oauth_pat branches. If an attacker-controlled or compromised configured Atlassian instance returns a redirect to an internal address, those sessions can follow the redirect without revalidating its destination.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

