CVE Vulnerability Catalog

Translated CVE descriptions from NVD NIST - in English

Browse vulnerabilities by package

CISA KEV catalog updated: (v2026.11.06)

Weekly CVE digest

One email a week with newly published vulnerabilities worth knowing about. No account needed.

This digest covers new vulnerabilities in general, not your servers. If you want to know which of them actually run in your infrastructure, that is what Secvalis does: it scans your machines and reports only what concerns them.

I agree to receive the weekly CVE digest at the address above. I can withdraw this consent at any time using the link in the footer of every message.

CVE-2026-64188
High

In the Linux kernel's Qualcomm rmnet driver, a use-after-free vulnerability occurs when deleting a network interface. The rmnet_dellink() function frees endpoint memory before the RCU grace period ends, allowing concurrent readers to access freed memory, leading to a page fault and potential code execution.

CVE-2026-58484
High

In Network-AI (TypeScript/Node.js multi-agent orchestrator) before version 5.12.2, a vulnerability was found where the 'path' field in backup manifest files is trusted. An attacker can place a malicious manifest, causing arbitrary file or directory deletion during backup pruning.

CVE-2026-54538
HighEPSS 52%

Vulnerability in xrdp due to improper validation of the totalLength field in the RDP protocol header. An unauthenticated attacker can send a crafted packet, causing an infinite CPU loop and resource exhaustion.

CVE-2026-46701
High

Network-AI before version 5.4.5 defaults to an empty MCP SSE secret, allowing any unauthenticated request to be accepted. Additionally, the CORS header permits access from any origin, enabling an attacker to remotely invoke all 22 MCP tools on a local server.

CVE-2026-46555
High

WhatsApp MCP Server before version 0.2.1 has critical vulnerabilities: unauthenticated HTTP API on port 8080, missing Host header validation, and an absolute `media_path` parameter in the `/api/send` endpoint. This allows local processes to send WhatsApp messages and steal files, and remote attackers to exploit DNS rebinding.

CVE-2026-44178
HighEPSS 59%

Heap-based buffer overflow in the virtual channel forwarding mechanism in xrdp versions 0.10.6 and earlier. An authenticated remote attacker can send a crafted virtual channel message, causing heap memory corruption.

CVE-2026-41521
HighEPSS 52%

Integer overflow vulnerability in xrdp when processing screen updates in vnc-any mode. A malicious VNC server can send crafted image dimensions, leading to incorrect memory allocation and out-of-bounds read.

CVE-2026-40187
HighEPSS 57%

In egroupware version 26.0 and earlier, an authenticated administrator can achieve OS-level Remote Code Execution (RCE) by uploading a malicious eTemplate XML file (.xet) to the VFS /etemplates mount. The Widget::expand_name() method passes template widget attribute values directly into a PHP eval() call with only double-quote escaping applied - backtick characters are not escaped. In PHP, backticks inside a double-quoted eval() string execute shell commands, allowing an admin-level user to escalate from web application access to arbitrary OS command execution on the server.

CVE-2026-39879
High

Missing sanitization in afsql_dd_run_query in syslog-ng before 4.12 leads to SQL injection from an untrusted source. Not in default configuration, requires manual SQL driver setup. Fixed in syslog-ng 4.12, Premium Edition 8.2, and Store Box 7.8.

CVE-2026-39385
High

Frappe LMS version 2.51.0 and earlier allows users to bypass payment validation for courses by using an unrelated batch. This is fixed in version 2.52.0.

CVE-2026-35591
High

Vulnerability in libvips up to version 8.18.1. The tiffload operation may incorrectly determine the number of channels in JPEG/JPEG2000 tiles within a TIFF image, leading to a buffer overflow. Fixed in version 8.18.2.

CVE-2026-33327
High

Vulnerability in libvips up to version 8.18.0. The vipsload operation may incorrectly determine image dimensions, leading to an integer overflow and subsequent heap-based buffer overflow. Fixed in version 8.18.1.

CVE-2026-32825
High

In dataCycle-CORE before version 25.07.3, there are no limits on login attempts via browser or API. Account locking is disabled and requests are not rate-limited, allowing continuous password guessing.

CVE-2026-32824
High

In dataCycle-CORE before version 25.07.3, an authenticated low-privileged API user can supply custom URLs in password reset or confirmation flows. These URLs are embedded in emails without host allowlisting.

CVE-2026-32821
High

In dataCycle-CORE before version 25.07.3, an authenticated API user can use their access token to query the collection API for permissions of another user by supplying their email. If the target user has collections, they may be exposed. In V4, a known collection can be modified via add/remove items without proper authorization.

CVE-2026-32820
HighEPSS 59%

In dataCycle-CORE before version 25.07.3, the documentation and static Markdown renderer improperly handles attacker-controlled path segments. An unauthenticated attacker can use directory traversal sequences to read arbitrary .md files outside the intended docs or static directories.

CVE-2026-32806
High

Vulnerability in dataCycle-CORE before version 26.06.08 (including 25.07.3). The /remote_render endpoint does not restrict which partials can be rendered, allowing a low-privileged authenticated user to access server-side rendered admin content.

CVE-2026-63429
High

Vulnerability in HeyForm before version 3.0.0-rc.9: the POST /api/upload endpoint lacks authentication and form-context validation. Any anonymous user can upload a file (up to 10 MB) and receive a public URL.

CVE-2026-46415
High

The Caddy Defender plugin before version 0.10.1 used `r.RemoteAddr` instead of the resolved client IP (`client_ip`) for request blocking. In deployments behind a trusted proxy, CDN, or load balancer, `RemoteAddr` points to the proxy's address, allowing attackers from blocked IP ranges to bypass the blocking rules.

CVE-2026-45713
High

Mailpit before version 1.30.0 does not limit the size of data sent via SMTP or HTTP, allowing an attacker to send very large messages. This causes a spike in RAM consumption (up to 7-10x amplification), potentially leading to an OOM kill.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS